90

Downloaded Ubuntu tweak and set window controls to the right side. Only some programs follow the rule. Pidgin as an example has window controls on the right. But Chrome, Thunderbird, Geany, still have controls on the left.

How can I move ALL window controls(close/min/max) to the right (or left)?

2
  • It's impossible right now. Our only chance is to vote on this bug. Sep 9, 2016 at 23:16
  • download GNOME Tweaks from app store.
    – Rajat
    Oct 7, 2018 at 16:40

12 Answers 12

69

14.04

Short answer:

It seems that Canonical went the totalitarian way and ordered that users should not be allowed to change the buttons position (you can find more technical details of this change on the bottom of this post).

As for now the only way to have windows buttons on the right side in 14.04 is to switch from Unity to the Gnome Flashback session (what I personally recommend). More details on how to do that are presented below.

Switching to Gnome Flashback:

Open terminal and run the following commands:

sudo add-apt-repository universe
sudo apt-get update
sudo apt-get install gnome-session-flashback

Next logout and select Gnome Flashback session in login manager.

enter image description here

You can select between Metacity and Compiz managers. Metacity is more lightweight, however it lacks some effects. With Compiz you will get more similar experience to Unity. You can speed up Compiz by turning off animations plugin (use compizconfig-settings-manager).

While in Gnome Flashback session, to move buttons to the right open a terminal and enter this command:

gsettings set org.gnome.desktop.wm.preferences button-layout 'menu:minimize,maximize,close'

But I want to still use Unity:

As I wrote in technical details, Canonical hardcoded buttons position in their Unity plugin. Changing of this needs this plugin to be patched by some third-party programmers. As for now such a patch is not available. (When such a patch will be published, please edit this answer and post it here.)

Technical details of the change:

Unity uses Compiz as its window manager. They used Compiz plugin called GTK Window Decorator to draw window borders and titlebars. This plugin draws borders basing on the Metacity theme, which itself is highly configurable. That is why until 14.04 we had been changing Metacity settings in order to change buttons position [1].

Now they have resigned from using gtk-window-decorator and implemented window decoration right in their Unity Compiz plugin. They deliberately hardcoded buttons position on the left side and do not expose any position switch to the user, in order to maintain "consistent user experience", as they call it [2].

10
  • 14
    Why would they do this? Every single time I want to minimize or close a window I have to look around for the buttons. It's not just Windows that sets the precedent for this, it's the whole Western ltr convention.
    – thepeer
    May 29, 2014 at 13:47
  • 3
    Just a note to say you can still use Compiz (and Wobbly Windows!) with Gnome Flashback. Really, the only thing you lose is the Dash. Jul 22, 2014 at 13:08
  • 9
    Hardcoding these buttons on the left side is bad news for regular right handed user. I like Dash functionality, and won't go back because of these buttons, but it's just yet another stupid decision toward blindly copying OSX design - copycats.
    – zetah
    Oct 27, 2014 at 8:18
  • 2
    @PiotrJurkiewicz Why do you personally recommend Gnome Flashback session? I am curious because I discovered that in my case it is much much faster than Unity. Am I imagining this? Are there additional reasons to switch to Gnome Flashback session? Thanks. Jan 9, 2015 at 2:21
  • 2
    +1 for your insightful posting; minus f***ing 1000 for Canonical.
    – GhostCat
    Jul 22, 2015 at 11:40
49

12.04 until 13.10

from 12.04 and newer gconfeditor wont work use this:

gsettings set org.gnome.desktop.wm.preferences button-layout ':minimize,maximize,close'

14.04

@Piotr Jurkiewicz answer

7
  • 1
    Protip: if you delete the colon and forget to add it back, you'll loose your menu bar and it will be really annoying/buggy behavior (the terminal doesn't show any text) until you set it back and restart.
    – Carrotman
    Feb 14, 2013 at 18:33
  • 1
    Worked for me in 12.04
    – Ciske
    Sep 14, 2013 at 14:24
  • Works for windows which are not maximized.. But what about maximized windows? Dec 18, 2013 at 11:54
  • not for this topic, but you can disable the move stuff to top bar in ubuntu to not have that behaviour, that can break standard behaviour in ubuntu so I wouldn't recommend it.
    – Alex R
    Dec 18, 2013 at 13:21
  • Protip: you can also use GNOME's built-in dconf editor to do this. Also thank you! Aug 3, 2016 at 9:55
33

For Ubuntu 12.10 and lower.

  1. Open terminal
  2. Type: gconf-editor
  3. Go to Apps -> Metacity -> General
  4. Find: button_layout
  5. Change value to: menu:minimize,maximize,close

For Ubuntu 10.10 the string needs to be menu:minimize,maximize,close, with a comma in the end of the string.

2
  • 1
    Protip: if you delete the colon and forget to add it back, you'll loose your menu bar and it will be really annoying/buggy behavior (the terminal doesn't show any text) until you set it back and restart.
    – Carrotman
    Feb 14, 2013 at 18:40
  • This does not work in Ubuntu 17.04 either. Anybody help, please. Oct 7, 2017 at 7:01
27

For 12.04 and 12.10

Unity

Run this command in a terminal:

gsettings set org.gnome.desktop.wm.preferences button-layout ":minimize,maximize,close"

Note that this will only change the position of the window controls of non-maximized windows. The maximized windows will continue to have their window controls on the left in title bar. To set the controls back to being on the left side:

gsettings set org.gnome.desktop.wm.preferences button-layout "close,minimize,maximize:"

GNOME-shell

gsettings set org.gnome.shell.overrides button-layout ":minimize,maximize,close"
2
  • 4
    For those who want to move buttons to the left "close,minimize,maximize:" Oct 23, 2012 at 11:18
  • Thank you so much! That makes GNOME Shell SO much more usable for me :D (just moving the 'close' to the left) Now I can close a program and get straight to Activities...
    – Ads20000
    Apr 24, 2014 at 20:43
14

You can also download Ubuntu Tweak, which has an easy GUI option to switch the window buttons to the right. It's found under the Windows Manager Settings option, under the Desktop category. Just select the "Right" radio button and you're done.

5
  • 1
    I used Ubuntu Tweak to do it and in my opinion, it is the easiest method.
    – ricky
    Aug 2, 2010 at 16:33
  • It is surely the easiest method.
    – User
    Oct 22, 2010 at 3:02
  • 7
    That doesn't work in 14.04 though.
    – sEver
    Jan 13, 2015 at 19:37
  • Using 15.10, doesn't work.
    – yainspan
    May 23, 2016 at 18:08
  • No longer works in 16.04, see this bug Sep 20, 2016 at 23:05
5

Ubuntu 14.04:

Far more easy than I thought (or remember it was in previous versions)

  1. Install the unity tweak tool
    sudo apt-get install unity-tweak-tool
  1. Open System Tools -> Preferences -> Unity Tweak Tool

  2. On the tab "Window Controls" (last tab) you can now choose between Left or Right.

6
  • Thanks +1. That said, unless I use exclusively the command line, I prefer sticking with the tools provided by the GUI environment to which I am sticking. So, another way to install the unity tweak tool: Launcher > Search: tweak > select: Unity Tweak Tool (2nd item in the search results). Jan 9, 2015 at 2:29
  • No longer works in 16.04, see this bug Sep 20, 2016 at 23:05
  • @DanDascalescu, I believe you already commented that and downvoted 10 days ago. I have specifically and clearly stated Ubuntu 14.04 above, and it will work with ubuntu 14..04 forever. If you for some mysterious reason got the impression that the answer was intended to be a generic solution that should work with any prior and future version of ubuntu, from 4.10 to 22.04 in jan 2021, then I cant help that. Sep 21, 2016 at 0:22
  • Oh, sorry, didn't realize. My vote is locked, but happy to revert it if you make an edit to the post. Sep 21, 2016 at 2:43
  • Didn't work for me. Unity tweak simply doesn't save.
    – userfuser
    Feb 3, 2017 at 1:02
3
gsettings set org.gnome.shell.overrides button-layout :close,minimize,maximize

Try the above command in the terminal (Ctrl+Alt+T). This will work. It actually follows the principle of slicing in Python. You can give close,minimize,maximize: to move the keys to left. Further u can interchange the positions of close,minimize and maximize :)

2
  • I got an error: No such schema 'org.gnome.shell.overrides'. Would this work in 15.10?
    – yainspan
    May 23, 2016 at 18:09
  • This is the same answer as jokerdino's but with a syntax error (misses quotes around ":close,minimize,maximize". Also, it no longer works in 16.04 even if you add the quotes. I'd delete the answer if it were mine. Sep 9, 2016 at 22:53
3

For ubuntu 17.10 simply type in terminal:

gsettings set org.gnome.desktop.wm.preferences button-layout 'close,maximize,minimize:'
1
  • Also works in 18.04. It would be better if someone could update the existing highest-voted answer.
    – slhck
    Jun 11, 2018 at 13:00
2

System>Preferences>Appearance Change the theme to something other than Radiance/Ambiance.

3
  • I don't want to change the theme!
    – User
    Jul 31, 2010 at 17:40
  • 1
    @Shubhkarman If you are using the default theme, and switch the button layout, it will look like crap, because the buttons are designed to be in a certain order. To fix that you could install Ambiance_R (or Radiance_R) gnome-look.org/content/show.php?content=123927
    – Isaiah
    Jul 31, 2010 at 17:59
  • 3
    Wait... Pynt, it doesn't do that anymore. It used to (early in development) but it was fixed with a patch to Metacity. Now you can put the buttons any order you want, and it'll still look good.
    – dieki
    Aug 1, 2010 at 1:28
1

I found that the gconf-editor suggestion just reversed the order of the buttons. They remained on the right hand side of the window. To switch buttons to the left hand upper corner, I used System Settings > Ubuntu Tweak > Tweaks > Window. Window Control

1

Some applications do not adhere to the global window decorations, and Chrome is an example of this behaviour. Right-click its window border and choose "use system window decoration". Pretty much every major application other than Chrome uses the default, system-wide kind, so peobably this is all you will have to do.

Also, I strongly recommend you leave the button order as it is, because this change did not come out of nowhere. For instance, in Unity, maximized windows have their buttons in the top-left corner as well, and this tweak won't change that.

1
  • I had to restart Chromium for the buttons on the left to show up after switching to "Use system title bar and borders" ([v34] it had no title bar or borders after the switch, so I had to quit it from Launcher). Jul 21, 2014 at 14:21
-1

In dconfig Editor go to org>gnome>desktop>wm>preferences>button-layout and change it to :minimize,maximize,close and hit enter.

Be sure that you include the colon before minimize.

I have two laptops using the gnome desktop environment. One I upgraded from 12.10 to 14.04 and the other was a fresh install of 14.04. The upgrade kept the old setting I checked it against the fresh install. It worked when I changed the fresh install.

1

Not the answer you're looking for? Browse other questions tagged or ask your own question.