I just installed Server 12.04 onto a spare desktop. Everything is working well except when I try to ssh using my external ip address.

My /ect/network/interfaces file:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static

I have tried to use dhcp as well, but still no luck. I know the server can connect to the outside because it can update, but when I try to ping an outside ip address I receive no response packets. I've run older ubuntu servers before, but I've never ran into this problem. I can ssh in using my internal ip addresses, so normally I would think it was a problem with port forwarding, but because of the lack of response pings I think it is a configuration error.

  • If your server can otherwise connect to the outside (updates, browsing, etc.) but cannot ping, your router/firewall may be blocking ICMP (ping's protocol) but allowing the standard HTTP which is used for updates, etc. – ish Aug 10 '12 at 10:06
  • you ever get anywhere with this OP? – Jamie Hutber Mar 31 '13 at 9:18

I summarize two different problems from your description

  1. You cannot establish an SSH connection from any external IP address to your server
  2. Once logged on to the server (from internal network) you still cannot ping an external IP address from the server.

Since you mention port-forwarding and show a private IP on your server it appears that there is NAT/NAPT in action.

The reasons for out-going ping failure and inbound SSH connect failures could be different

  1. ping may be blocked (even at the NAT configuration)
  2. Inbound connections need to be forwarded through NAT
    • your inbound SSH problems may be of this kind
    • lack of this configuration will not stop outbound translation and connectivity
  3. have you tried telnet www.google.com 80 ? or to some other simple HTTP site?
  4. This Serverfault question on ping over TCP my be of interest.
| improve this answer | |
  • I realized today after trying to update I was wrong. When I attempt to use the static IP instead of dhcp it won't connect to update. Any ideas what could be wrong with my static configuration? – RCPhysics Aug 11 '12 at 20:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.