31

I connected an external screen to my laptop, but my desktop didn't automagically extend to it, as it used to do about a year ago (older version of Ubuntu).

I went to the display settings. The screen was listed there (correct resolution, brand name, etc.). But when i put the switch on 'on' and click 'apply', i get this error:

Failed to apply configuration: %s

GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface `org.gnome.SettingsDaemon.XRANDR_2' on object at path /org/gnome/SettingsDaemon/XRANDR

It's been like this for a few months now, but i'd really like to be able to use an external screen/beamer again.

Any ideas?

Thanks.

  • 1
    Try using the arandr tool, worked for me. sudo apt-get install arandr It's just a simple graphical frontend for xrandr. It's easy to use and self-explanatory. – Sasha Shepherd Feb 18 '13 at 9:08
  • I had the same issue: Tried the <code>dconf</code> route, but it crashed unexpectedly. Took Sasha Shepards advice with ARandR and it worked great. Ubuntu 12.04 LTS Memory: 5.9 GB Processor: AMD Phenom(tm) II x4 840T Processor x 4 Graphics: GeForce GTX 650/PCIe/SSE2/3DNOW! OS Type: 32-Bit Disk: 148GB Hope this helps! – user314658 Aug 11 '14 at 18:22
31
+50

dconf write /org/gnome/settings-daemon/plugins/xrandr/active true did nothing and arandr looks pretty incomprehensible to me. If you are otherwise stymied, it is worth giving xrandr a try. The documentation is here: http://www.thinkwiki.org/wiki/Xorg_RandR_1.2#First_discover_what_we_have

And I was able to fix this by doing:

xrandr --current
xrandr --output VGA1 --off
xrandr --output VGA1 --auto --right-of LVDS1

Let me explain these:

The first command is to see what displays I have connected.

$ xrandr --current
Screen 0: minimum 320 x 200, current 3200 x 1080, maximum 8192 x 8192
LVDS1 connected 1280x800+0+0 (normal left inverted right x axis y axis) 261mm x 163mm
1280x800       60.0*+
1024x768       60.0
800x600        60.3     56.2  
640x480        59.9  
VGA1 connected 1920x1080+1280+0 (normal left inverted right x axis y axis) 509mm x 286mm
1920x1080      60.0*+
1280x1024      60.0  
1440x900       59.9  
1280x800       59.8  
1152x864       75.0  
1024x768       70.1     60.0  
800x600        60.3     56.2  
640x480        66.7     60.0  
720x400        70.1  
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)

There is much extraneous data, but I only need the names of the two displays. I see:

LVDS1 connected

and

VGA1 connected

And I think it is safe to assume that VGA is the external monitor. So then I turn it off

xrandr --output VGA1 --off

and back on again

xrandr --output VGA1 --auto --right-of LVDS1

and when I move my cursor to the right edge of the laptop screen, it appears on the external monitor. Success.

  • 2
    Thank you so much for explaining this in a very simple nature. You've made my life so much better knowing that I can run these three commands to get my displays to work right. – Zlatty Jan 30 '14 at 21:44
  • 1
    Thanks, worked here with Ubuntu 14.10 and i3. I have two monitors, and lost one. I did this in one step since I was worried about killing the wrong one: xrandr --output DVI-I-2 --off && xrandr --output DVI-I-2 --auto --right-of DVI-I-1 – moodboom Feb 22 '15 at 15:13
  • 1
    Doing --off and subsequently --auto worked for me. Now how to make this permanent... – Jeffrey Blattman Feb 28 '18 at 17:10
6

Calling:

dconf write /org/gnome/settings-daemon/plugins/xrandr/active true

solved the problem for me.

Depending on your graphics card, its specific configuration tool can do the dual screen configuration too e.g. nvidia-settings, ... an

  • Wow, I had the same issue and this worked for me, thanks! – Sheldon Oct 30 '12 at 14:10
  • Just magic. How this works? Is it a permanent solution? – Philippe Delteil Jun 2 '18 at 1:30
1

I came here having issues on display settings after installing Cinnamon in Xubuntu. Doing so gave me two "displays" dialogs, the ubuntu one giving me the gdbus error. Open the other one (Cinnamon) to get it right.

https://github.com/linuxmint/Cinnamon/issues/2506#issuecomment-26671162 - thanks

0

For me installing the gnome-shell desktop and once switch to that and change this setting from there resolved the issue for unity as well.

  • You should add more details to your answer. Like how to install gnome-shell desktop. Should we keep unity and gnome-shell both installed or remove them after setting? Where should the setting be done after installing gnome-shell desktop? – Gaurav Agarwal Aug 10 '13 at 21:26
0

Try disabling the graphics card drivers, restart, try if it works.

After booting on a live usb and managed to do exactly what I want with the displays (laptop screen on the left- external monitor on the right), I concluded that something must be going on with the drivers of my graphics card. So I disabled them via System Settings>Additional Drivers, rebooted and everything worked as I wanted to.

PS:Tried most of the above, did not seem to work for me.

Hope it helps you too.

0

I had the same using Settings > Display on 12.04 LTS.

It seems the Gnome Settings Daemon needs to be active for the changes to take effect, and I had accidentally turned it off from the Startup Applications.

Hope this helps.

0

Restarting gnome-settings-daemon fixed it for me:

gnome-settings-daemon --replace > /dev/null 2>&1 &

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy