edit : already printed on windows-machine

Ubuntu 12.04, LJ 1018.

I've tried making foo2zjs from sourse.

I've downloaded firmware and placed it where necessarily manually from here

I've also tried this - same as manual dowload but with some patches like stoping cups, etc..

I've fixed usbfs: process 11200 (usb) did not claim interface 0 before use problems using sudo rmmod usblp as described here.

And now I have

Aug 10 11:51:59 pav /usr/sbin/hplj1018: foo2zjs: usb://HP/LaserJet%201018?serial=KP07RLV... download failed.
Aug 10 11:51:59 pav /usr/sbin/hplj1018: foo2zjs: loading HP LaserJet 1018 firmware /lib/firmware/hp/sihp1018.dl to CUPS USB device ...


Before that prinet was stucking on "Sending data to printer". Now it's code is "Not connected".


ben@pav:~$ lsusb 
Bus 001 Device 015: ID 03f0:4117 Hewlett-Packard LaserJet 1018

Thank you.

  • Hp printers work out of box, try reconnecting it. – BigSack Aug 11 '12 at 13:43
  • @BigGenius, 10хх series need to be pre-reflashed with official firmware, as far as I understood. And it doesn't work in Ubuntu. Or I've made something wrong. Anyway, everything is printed already. – MInner Aug 11 '12 at 13:52

Solved my problem by using the Terminal to install the driver. Open the Terminal (Ctrl+Alt+T) and run this command:

sudo hp-setup

Trying without sudo could not install the driver.

  • this seems like the answer. in 12.04, the driver is already installed (hplip) and connecting the printer asks for proprietary plugins and opens a terminal procedure that does not seem to work. other methods that i tried didn't work, but doing what is said here opens a HP GUI installer that does all the job, including adding the printer – user47206 Jan 23 '13 at 16:17
  • I noticed that the printer needs to be turned on while booting ubuntu, otherwise it does not work (you can manually copy the firmware after boot, but I do not remember the exact locations from/where to copy). – lenooh Jun 25 '14 at 21:35
  • if you get an error "error: hp-setup requires GUI support (try running with --qt3)" try installing hplip-gui – lenooh Nov 2 '14 at 16:07

Steps for solving hp 1018 problems

sudo apt-get remove hplip*
sudo apt-get install hannah-foo2zjs printer-driver-foo2zjs-common printer-driver-foo2zjs
sudo getweb 1018

reconect printer, no need for restart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.