13

My mouse wheel has stopped working. It doesn't scroll up and down when previously it worked. How can I configure what each button of the mouse does? I use Ubuntu 10.10.

2
  • I got the same issue. It worked for sometime and suddenly stopped working. The below fix did it for me. stackoverflow.com/questions/41774260/… – Venkat Nov 17 '17 at 4:02
  • @Venkat - your issue refers to something completely different: Linux-on-Windows vs Ubuntu's desktop – scruss Mar 23 '19 at 10:33
16

I was using a Logitech M510 wireless bluetooth mouse and was experiencing this issue with Ubuntu 18.04. I noticed that xev was not detecting any events for the scroll. To solve my issue, I turned off the mouse and then turned it back on and it worked.

5
  • 1
    Same mouse, same OS, same problem, same solution. Thanks! – Trevor Mar 4 '20 at 1:07
  • This should be the accepted answer, such an easy and quick fix! – Dylan Cali Aug 26 '20 at 17:31
  • Same for me, fixed lack of scrolling by unplugging the usb transmitter for the wireless mouse – Mark Dec 4 '20 at 3:53
  • Didn't work for me – Anshuman Kumar Jan 4 at 4:31
  • This worked for me on Ubuntu 20.04 with a Logi MX Master 3 mouse – Wouter Jan 15 at 14:57
9

How can I configure what each button of the mouse does?

You can check if your hardware is defect by running xev. Open a Terminal via Applications → Accessories → Terminal and type xev. A small white window should appear. When you move your cursor in that window, the command line output will tell you what x.org things your mouse is doing:

alt text

Button 4 in this example refers to scrolling up. If you don't get any output when scrolling, it may be your mouse is just broken.

When testing this, please ignore the output that is generated by your mouse moving around.

If you know your mouse isn't broken, and xev still doesn't give you any indication of the scroll wheel - if for example the mouse works on another computer, you are experiening a bug. In this case, read the Ubuntu Wiki's article on how to report bugs and file it against X.org. Make sure to include all details in your bug report, plus how to reproduce the error.

Be absolutely certain that your mouse works before filing a bug.


How can I configure what each button of the mouse does?

You can use btnx Install btnx to re-assign your mouse buttons. This will only work if they are detected properly.

alt text

The program will ask you to go through each of your buttons to configure them. Note: If xev doesn't recognise the scroll will, this program will not recognise it either.

3

I just solved this with my Dell XPS-15 and Dell bluetooth mouse by removing the batteries for a while and then reinserting them.

2
  • Quite funny a solution... :) – ThunderBird Jun 8 '20 at 19:08
  • No matter how it sounds like, not matter what we think of - a restart solves half of the world problems. It worked like a charm. – Viky293 Aug 28 '20 at 4:19
1

My solution with Precision mouse : unpairing (removing) bluetooth device and pairing it again.

0

Old thread, but none of the above worked for me.

This is what did work. From: https://ubuntuforums.org/showthread.php?t=1750708

I managed to get the scroll wheel working on my PS/2 mouse. As far as I know, this technique will only work on a PS/2 mouse.

As near as I can tell, Ubuntu detects some PS/2 mice as "generic" mice; that is, as only having two buttons and that's it.

I had to force the kernel to treat my mouse as a Microsoft Intellimouse to get the scroll wheel working. To verify this, look at /var/log/Xorg.0.log and see if there are some lines referencing a "PS/2 Generic Mouse".

CAUTION: The following commands change your GRUB configuration, and could conceivably render Ubuntu or other OS's unbootable.

Open a terminal, and type:

sudo nano /etc/default/grub

In nano, look for a line that starts with:

GRUB_CMDLINE_LINUX_DEFAULT=

Following this line will be some text in quotes.

Insert "psmouse.proto=imps" into the line, so that the whole thing looks something like:

GRUB_CMDLINE_LINUX_DEFAULT="psmouse.proto=imps quiet nosplash"

Then hit CTRL-X to exit, then Y to save your changes.

You will then need to type:

Code:

sudo update-grub

to update your boot menu. You should then be able to reboot and enjoy a functional scroll wheel. Additionally, /var/log/Xorg.0.log should now recognize your mouse as "ImPS/2 Generic Wheel Mouse".