12

I use ubuntu 11.04.

My boost version:

  sam@sam:~/code/ros/pcl$ apt-cache  showpkg libboost-all-dev
  Package: libboost-all-dev
  Versions: 
  1.42.0.1ubuntu1 (/var/lib/apt/lists/tw.archive.ubuntu.com_ubuntu_dists_natty_universe_binary-amd64_Packages) (/var/lib/dpkg/status)
   Description Language: 
                   File: /var/lib/apt/lists/tw.archive.ubuntu.com_ubuntu_dists_natty_universe_binary-amd64_Packages
                    MD5: 72efad05a3c79394c125b79e1d4eb3a7


  Reverse Depends: 
    libvtk5-dev,libboost-all-dev
    libfeel++-dev,libboost-all-dev
  Dependencies: 
  1.42.0.1ubuntu1 - libboost-dev (0 (null)) libboost-date-time-dev (0 (null)) libboost-filesystem-dev (0 (null)) libboost-graph-dev (0 (null)) libboost-iostreams-dev (0 (null)) libboost-math-dev (0 (null)) libboost-program-options-dev (0 (null)) libboost-python-dev (0 (null)) libboost-regex-dev (0 (null)) libboost-serialization-dev (0 (null)) libboost-signals-dev (0 (null)) libboost-system-dev (0 (null)) libboost-test-dev (0 (null)) libboost-thread-dev (0 (null)) libboost-wave-dev (0 (null)) 
  Provides: 
  1.42.0.1ubuntu1 - 
  Reverse Provides: 
  sam@sam:~/code/ros/pcl$                                                       

How to upgrade boost to 1.44+ by using apt tools?

Thank you~


When I run apt-add-repository,it shows:

  sam@sam:~/code/ros/pcl$ sudo apt-add-repository ppa:timklingt/ppa
  Error reading https://launchpad.net/api/1.0/~timklingt/+archive/ppa: GnuTLS recv error (-9): A TLS packet with unexpected length was received.
  sam@sam:~/code/ros/pcl$       

How to fix it?

Thank you~


I try to install libboost1.46-all-dev:

  sam@sam:~/code/ros/pcl$ sudo apt-get install libboost1.46-all-dev
  Reading package lists... Done
  Building dependency tree       
  Reading state information... Done
  Some packages could not be installed. This may mean that you have
  requested an impossible situation or if you are using the unstable
  distribution that some required packages have not yet been created
  or been moved out of Incoming.
  The following information may help to resolve the situation:

  The following packages have unmet dependencies:
   libboost1.46-all-dev : Depends: libboost1.46-dev but it is not going to be installed
                          Depends: libboost-date-time1.46-dev but it is not going to be installed
                          Depends: libboost-filesystem1.46-dev but it is not going to be installed
                          Depends: libboost-graph1.46-dev but it is not going to be installed
                          Depends: libboost-iostreams1.46-dev but it is not going to be installed
                          Depends: libboost-math1.46-dev but it is not going to be installed
                          Depends: libboost-program-options1.46-dev but it is not going to be installed
                          Depends: libboost-python1.46-dev but it is not going to be installed
                          Depends: libboost-regex1.46-dev but it is not going to be installed
                          Depends: libboost-serialization1.46-dev but it is not going to be installed
                          Depends: libboost-signals1.46-dev but it is not going to be installed
                          Depends: libboost-system1.46-dev but it is not going to be installed
                          Depends: libboost-test1.46-dev but it is not going to be installed
                          Depends: libboost-thread1.46-dev but it is not going to be installed
                          Depends: libboost-wave1.46-dev but it is not going to be installed
  E: Broken packages
  sam@sam:~/code/ros/pcl$                               

What's these error means?

And how to solve it?

Thank you~

2 Answers 2

11

EDIT: Boost-latest is not being updated since 2014 and the latest version on it is 1.55

The boost-latest PPA contains all the versions of libboost and fixed it for me!

sudo add-apt-repository ppa:boost-latest/ppa
sudo apt-get update

now you can install the version you desire, the latest at the time of writing is 1.55:

sudo apt-get install libboost1X.55-all-dev
5
  • 1
    sudo apt-get install libboost1X.55-all-dev, doesn't work, sudo apt-get install libboost1.55-all-dev does.
    – tonylo
    Feb 11, 2015 at 22:42
  • And still, it is 1.55. :( Sep 21, 2016 at 11:27
  • 7
    boost-latest is misnamed. It stopped updating in 2014 =(
    – Zach
    Oct 4, 2017 at 16:15
  • Consider alternatives like launchpad.net/~mhier/+archive/ubuntu/libboost-latest
    – Clément
    Feb 1, 2020 at 23:01
  • @Clément unfortunately, he stopped maintaining this PPA too...
    – kebs
    Mar 12, 2021 at 12:12
2

Unfortunately, the latest official version of boost available in the repositories for Natty (11.04) is 1.42.

You can try installing it from an unofficial PPA, for example this one.

sudo apt-add-repository ppa:timklingt/ppa
sudo apt-get update
sudo apt-get install libboost1.46-all-dev
5
  • I have edited my original post. And also have apt-add-repository problem. How to fix it? Thank you~
    – sam
    Aug 10, 2012 at 5:30
  • I found that I can run with 'sudo apt-add-repository ppa:tim-klingt/ppa'. But after I update, ubuntu still can't find libboost-dev-all. How to fix it? Thank you~
    – sam
    Aug 10, 2012 at 5:36
  • Please try libboost1.46-all-dev package -- also edited answer.
    – ish
    Aug 10, 2012 at 5:38
  • I have edited my original post. And also have dependency errors. How to fix it? Thank you~
    – sam
    Aug 10, 2012 at 5:45
  • 2
    install first libboost1.46-dev, than libboost1.46-all-dev
    – ulkas
    Nov 29, 2013 at 3:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .