I'm running XFCE remotely via lightDB with xdcmp enabled.

How do I disable the desktop background, (preferably for remote sessions only)?

Note if I select Menu->Settings->Desktop and select Background Image:none I still get a solid background. This is not good enough. Remember X is a network protocol, I need to client the local desktop with remote applications over the top. When accessing remotely I only require the panel and the window-manager.

  • I think this s a function of your X server (on the local machine) rather than the X client window manager. What are you using? – StarNamer Aug 9 '12 at 23:18
  • The point is that the desktop background is essential just a special client 'window' so the server needs to recognise it and discard it. – StarNamer Aug 9 '12 at 23:25
xfdesktop --quit

and save the session.

1) it's not an Xserver function, as even running rootless the window manager paints a background. 2) Setting the background to "Transparent" results in a black backdrop. Not Transparent. 3) One can successfully disable the desktop icons and context menu. But the background remains.

  • I get neat glitch art looking desktop if I set the background to "transparent". It's probably GPU+driver dependent – JamesTheAwesomeDude Mar 20 '17 at 16:51

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.