Reading AskUbuntu and on the forums, I am trying to find out what to do about a WebGL and Google MapsGL problem (described in a Google forum thread starting at post #5).

Specifically, Google's MapsGL works perfectly in Windows 7 (on this same machine with dual-boot), but on Ubuntu, the Photo Tour and 45 Degree Satellite View show grey blurry blobs (see screen-shot).

According to post #10, I may have better luck with an updated driver. I seem to have Mesa 8.0.2 installed, and see from the Mesa website that 8.0.3 is available.

I have added PPA ppa:ubuntu-x-swat/x-updates, but the only two items it provides for update are xdiagnose and xserver-xorg-video-intel. These aren't the Mesa drivers, are they?


  1. Would it help to update my Mesa drivers?
  2. If so, how would I go about it?
  3. If not, what can I do to fix the problem?

I would be happy to try it out as long as I could roll back the changes should they fail.

More information:

  • Ubuntu 12.04 64-bit fully updated.
  • Firefox 14.0.1 gives the error
  • Chromium 18.0 will not run MapsGL at all (see post #2)
  • EDIT: Chromium 20.0 does work if started as chromium-browser --ignore-gpu-blacklist. The latest Chromium is available from the PPA ppa:webapps/preview (thank you, mikewhatever — see his answer below).
  • EDIT: Chromium has a setting that works the same way as --ignore-gpu-blacklist. Go to chrome://flags and enable setting Override software rendering list.

Thank you.


How about just enable "Override software rendering list" in chrome://flags, it works in my chromium 18.0.1025.168.

  • Thank you, caasi. That does indeed work in Chromium, which is a cleaner solution than --ignore-gpu-blacklist. All we need to do now is to find out how to get Firefox to work! – Paddy Landau Aug 21 '12 at 7:38
  • That's strange, WebGL works with my intel GMA X3100 and FireFox 14.0.1. – caasi Aug 25 '12 at 17:40
  • Thanks for the note about your GMA X3100. How do I find out which hardware version I have? – Paddy Landau Aug 26 '12 at 7:01
  • Sorry for my late reply, I just checked my notebook's spec on the Internet and try to find new drivers for my card, then I found chrome://flags. – caasi Oct 15 '12 at 20:51

According to the GPU info you've posted, WebGL is unavailable for your hardware. I suspect that Intel graphics/drivers are not up to the job, and had been blacklisted. I don't think updating mesa will help. You might want to try launching Chromium like this:

chromium-browser --ignore-gpu-blacklist

...but expect problems. It would not have been disabled, had it worked well.

Info source

PS: By the way, there was a PPA to update Chromium. The current version is at 21, and 18 is many months old.

For Firefox, the situation is about the same. If you wish to enable hardware acceleration, follow the wiki page.

  • Thanks for the comments. Your command should show chromium-browser, not chromium. You are right that problems remain when I do this. I have searched for the right PPA and found two: ppa:chromium-daily/stable and deb http://dl.google.com/linux/chrome/deb/ stable main, but neither of them showed me an updated Chromium (after reloading the apt cache). I find this most puzzling, as the relevant web pages say that there are updates. – Paddy Landau Aug 10 '12 at 10:34
  • Thanks for the correction, and see the edit above conserning the PPA. – mikewhatever Aug 10 '12 at 12:57
  • Thank you for the PPA. Post #14 on the Google thread explains the problem clearly; in summary, the updated Chromium works provided I use ignore-gpu-blacklist, but Firefox (even after a reboot) still has the same problem of blurry grey blobs. I'm voting up your answer because of your help, but it's still not quite an answer because Firefox is still a problem. – Paddy Landau Aug 10 '12 at 17:05
  • Firefox has the same (or similar) blacklisting, you can see if it's on or off at the about:support page. To force WebGL on, check out the wiki page by Mozilla. ...and thanks for upvoting. – mikewhatever Aug 10 '12 at 17:23
  • Thanks. Google Maps accepts WebGL in Firefox, so that's not where the problem lies. In about:support, the only item with "blacklist" in is gfx.blacklist.suggested-driver-versionMesa 7.10.3. Obviously, my hardware is capable (it works in Windows Firefox, and on Linux Chromium with --ignore-gpu-blacklist), so it should work in Linux Firefox. How can I find out which version of Mesa I have? In the package manager, lib*mesa shows 8.0.2-0ubuntu3.1, so would it mean that I have 8.0.2 and therefore that the Firefox blacklist is irrelevant? – Paddy Landau Aug 11 '12 at 8:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.