552

When I login, nothing happens.

I am presented with my desktop wallpaper.

Blank desktops suck

No Dash, no Launcher, nothing.

  • 1
    IMHO this is a bug, but I have this since today. Could only find this bug bugs.launchpad.net/ubuntu/+source/unity/+bug/1212987 I followed the recommendations here: askubuntu.com/questions/17381/… Unity did reset but is not working OK, workspaces don't work, even if I enable or disable or change amount. No difference. Put plugin also crashes unity, – Janghou Aug 16 '13 at 9:58
  • 2
    My problems started after switching from nouveau drivers to NVIDIA drivers (system settings / hardware tab). – DanielaWaranie Dec 18 '14 at 12:35
  • 19
    After many spent days and many SO threads read, I found that this seems to be an Ubuntu open Bug (Status 'Incomplete' as of Juli 2015). More information about it here: bugs.launchpad.net/ubuntu/+bug/1285444 The quick solution seems to be: $ mv ~/.config/dconf/user ~/.config/dconf/user.old – user9869932 Jul 8 '15 at 19:04
  • 1
    @julianromera's was the only solution on this thread that helped me – Dziamid Dec 29 '15 at 7:26
  • 1
    @julianromera answer was the only one that worked for me. – Paweł Adamski May 11 '16 at 11:50

35 Answers 35

0

I had the same problem and all the suggestions above failed for me.

I made the following steps:

  1. Installed kubuntu-desktop as an user interface alternative for Unity (login via ALT + Ctrl + F1, then sudo apt-get install kubuntu-desktop). Sure, you can choose other Unity alternatives.

  2. Restarted the machine and logged in via KDE.

  3. Created a temp user (let's name it alice) with admin rights.
  4. Copied my files in Alice's account.
  5. Deleted the original user (including the files)
  6. Created again the original user (same username, same rights)
  7. Copied the files from backup.
  8. Deleted the temp user (alice).

Then, you don't need KDE anymore. ;-)

  • Shouldn't it be better with juste xfce (not xubuntu-desktop!!) ? I think it's way less heavy to install (kde is so heavy) and not including *-desktop allows to ditch all "recommended" programs. – MrVaykadji May 24 '14 at 18:45
  • @MrVaykadji I chose kubuntu-desktop because I didn't remember another one. :-) – Ionică Bizău May 24 '14 at 19:34
  • Okay, but installing kubuntu-desktop will create a hell lot of dependencies, that's all I'm saying – MrVaykadji May 24 '14 at 19:35
  • KDE is more powerful than xubuntu; so in a certain way: if you accept the overhead of unity and the ubuntu-desktop; then KDE might be the better choice. On the other hand - if your focus is to have a system that reacts immediately you might want to install xubuntu in the first place. With xubuntu, the thunar file manager pops up in a second; nautilus under unity or gnome3; or dolphin with KDE will need at least 3 to 5 seconds. – GhostCat says Reinstate Monica Jun 4 '14 at 10:22
  • On Ubuntu 16.04 I installed xubuntu-desktop but even with DE there is only the desktop background after logging in. – Luís de Sousa Aug 2 '16 at 19:17
0

I had recently edited my .bashrc file with the line guake -r $(hostname) to automatically rename tabs whenever I opened a new tab in guake and everything was working perfectly. Then I restarted my computer a few days later and encountered this problem. I can only assume that trying to start guake without a valid display resulted in some error that completely destroyed something in the unity pipeline.

So if you've recently modified your ~/.bashrc try undoing changes.

0

I just had a black background with a mouse cursor. The following worked for me in addition to enabling the unity plugin again via ccsm, but first I had to do the following because it didn't even properly show the desktop: When doing unity --reset, it stopped at "show session" and some lines before it said "error loading plugin opengl", so i figured this must be related.. and it was! (just be sure to load your specific .so my nvidia installation had a different number of course, just do ls in the folder in described in the link

https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1342339

0

If the previous answers do not solve the problem, it might be that your HDD is so full that the system cannot work properly, and cannot manage to load the environment.

This can occur quite easily: you let something downloading overnight without a trigger to make it stop if the free disk space goes under a certain limit. At some point the system freezes because all the disk is full. Next morning you try to start it, and it does not load unity.

This, at least is what happened to me. The solution is simple: switch to TTY and delete manually a few things. Then reboot.

0

If nothing works out so far (from this thread itself, here or with initctl), try the following (tested on Ubuntu16.04):

  1. type in terminal:

    $ software-center

  2. then you can install Main Menu (alacarte) in Ubuntu software center

  3. right click on the panel and choose " add applets to the panel"
  4. then add applet "Menu" to panel.

Beware:

Don't install CompizConfig Setting Manager: it'll hang up your system during reboot , in the best case scenario.

Compizconfig is a dangerous toy now:it can break your Ubuntu installation!!

protected by Community Apr 16 '12 at 17:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.