When I login, nothing happens.

I am presented with my desktop wallpaper.

Blank desktops suck

No Dash, no Launcher, nothing.

  • 1
    IMHO this is a bug, but I have this since today. Could only find this bug bugs.launchpad.net/ubuntu/+source/unity/+bug/1212987 I followed the recommendations here: askubuntu.com/questions/17381/… Unity did reset but is not working OK, workspaces don't work, even if I enable or disable or change amount. No difference. Put plugin also crashes unity, – Janghou Aug 16 '13 at 9:58
  • 2
    My problems started after switching from nouveau drivers to NVIDIA drivers (system settings / hardware tab). – DanielaWaranie Dec 18 '14 at 12:35
  • 17
    After many spent days and many SO threads read, I found that this seems to be an Ubuntu open Bug (Status 'Incomplete' as of Juli 2015). More information about it here: bugs.launchpad.net/ubuntu/+bug/1285444 The quick solution seems to be: $ mv ~/.config/dconf/user ~/.config/dconf/user.old – xyz Jul 8 '15 at 19:04
  • 1
    @julianromera's was the only solution on this thread that helped me – Dziamid Dec 29 '15 at 7:26
  • 1
    @julianromera answer was the only one that worked for me. – Paweł Adamski May 11 '16 at 11:50

34 Answers 34

up vote 466 down vote accepted
+50

This answer applies versions of Ubuntu running Compiz.

This answer assumes Unity is being run through Compiz. If you don't have compiz installed this answer doesn't apply to you.

You just need to turn the Unity plugin back on. The problem is this is a pain in the bottom because you've now got no graphical method to do this. So:

  1. Try to open a terminal with Ctrl+Alt+T.
    This may not work but you can try right clicking on the desktop and selecting "Open terminal here." Otherwise, you may need to change to a "hard" terminal by pressing Ctrl+Alt+F1 and log in.

  2. Install compizconfig-settings-manager by running

    sudo apt-get install compizconfig-settings-manager
    
  3. Then run it with this:

    DISPLAY=:0 ccsm &
    

    The first part tells the terminal which display you want it to load on (otherwise it won't have a clue).

  4. If you switched to a TTY in step 1, switch back to the graphical server by pressing Ctrl+Alt+F7 (or Ctrl+Alt+F8 sometimes).
    There there should be a CompizConfig Settings Manager waiting for you.

  5. Find the Unity plugin. Enable it. You will be asked "Ubuntu Unity Plugin requires the plugin OpenGL. Enable Ubuntu Unity Plugin / Enable OpenGL"

  6. Everything should spring into life but if it doesn't, you might have to restart. You can do that by going back to the terminal and running sudo reboot.

  • 27
    Worked perfectly well for me. As a side note, I did not need to enter the TTY terminal, was able to use the terminal shortcut (ctrl + alt + t). – Tass Apr 24 '13 at 16:47
  • 12
    If you get to step 5 and don't see unity on the list, try this: sudo apt-get -f install && sudo apt-get --reinstall install unity – Collinux Mar 18 '14 at 1:18
  • 15
    Had this problem myself but I'm unlucky with the solution far, doesn't work for me, still get the same empty screen on Ubuntu 14.04 LTS 64bit. Will go over the steps again to check if any thing was missed. Lenovo X201S Thinkpad i7 2.0Ghz 8Gb RAM. Never had this issue with 12.04 LTS – therobyouknow May 19 '14 at 16:24
  • 12
    The fact that this is problem so common and long-lasting is, to me, rather disturbing. Does anyone know why this keeps happening, and what's causing it? – fouric Nov 21 '14 at 22:38
  • 10
    ccsm hangs on Loading Icons, but if I ctrl-alt-F7 back to the main display, the compiz options ARE there. I've enabled the Unity desktop, switched back to tty1 (ccsm has executed successfully)... but no Unity. Reboot: no Unity. If I reload ccsm, Unity is still selected and "on" but no Unity appears. – JeanSibelius Mar 7 '15 at 13:50

A solution good for me (has solved the same problem):

in a terminal:

export DISPLAY=:0   
sudo dconf reset -f /org/compiz/

and then

setsid unity
  • 3
    Fantastic. Works with Ubuntu Linux 13.04 Desktop in Parallels on Mac OS X. – Elliot Jul 1 '14 at 6:47
  • 4
    Thanks! Works with Ubuntu 14.04 too. I wonder why this happened out of the blue though :-( – Sadi Jul 30 '14 at 9:28
  • 4
    I needed export DISPLAY=:0 first. – Uri Oct 6 '14 at 17:30
  • 5
    sudo dconf reset -f /org/compiz/ Error spawning command line 'dbus-launch --autholaunch=c0c0f8bf86119c64ccb710000000006 --binary-syntax --close-stderr': child process exited with code 1 – JeanSibelius Mar 7 '15 at 13:54
  • 3
    One issue with this is that running dconf as sudo made my ~/.config/dconf/user file have root ownership (it had my user ownership before). I'm wondering if it should be done without sudo. This was much better than removing the file and starting from scratch! – Tim Tisdall Oct 5 '16 at 11:48

In 13.04 and 14.04:

unity --replace is deprecated. Instead, use the following:

dconf reset -f /org/compiz/ 
unity --reset-icons &disown

Reboot if it doesn't work right away.

  • 1
    This worked for me after installing appropriate drivers for my Nvidia graphics card. See my answer askubuntu.com/questions/288235/… – Thomas Arildsen May 2 '13 at 11:12
  • 2
    dconf reset command gives exitcode error 1 and won't work on 13.10. – Peterdk Oct 24 '13 at 16:10
  • 4
    enabling Unity plugins with ccsm fixed some of the problems, the rest were fixed with rm -r .Xauthority .ICEauthority .compiz-1/ .gconf/ .config/compiz-1/ .config/dconf/ – precise Mar 20 '14 at 19:29
  • 3
    Cannot autolaunch D-bus without X11 $DISPLAY. Nothing worked so far – jimifiki Dec 18 '14 at 4:06
  • 2
    It works for ubuntu 16.04 also , just resolved my issue – Priyadarshi Paul May 16 '16 at 19:04

For 12.10 and below:

Press Ctrl+Alt+T for a terminal and run ccsm, then re-enable your 'Unity' plugin.

You also may then need to run a unity --replace.

  • 5
    unity --reset is deprecated now and doesn't work. Is there a replacement? – Shahbaz Mar 11 '13 at 23:41
  • 5
    @Shahbaz - unity --replace. – horIzoN Apr 2 '13 at 14:48
  • 1
    @nerof61 also deprecated as of 13.04. See my answer below: askubuntu.com/a/286349/2638 – Brandon Bertelsen Apr 27 '13 at 2:40
  • 1
    neither --reset nor --replace worked for me with my Ubuntu 12.04 ..running the commands instantly displayed unity-panel-service: no process found Backend : ini Integration : true Profile : default Adding plugins Initializing core options...done ...I waited and waited, and then I couldn't, interrupted with ctrl + c.. and now looking to try what other answers suggested.. – precise Mar 20 '14 at 7:44

It is a good idea to check your graphics driver is configured to use hardware acceleration and it is configured to use OpenGL. Try searching Ask Ubuntu and Ubuntu Forums for information specific to your GPUs and Ubuntu flavour. For hybrid graphics users see the last section "Hybrid Graphics" below.

You might want to run the compizconfig-settings-manager Install compizconfig-settings-manager package and make sure that the Unity plugin is checked (see What are some of the issues with CCSM and why would I want to avoid it?).

For 12.04 And Newer

  1. Change to tty1 by pressing Ctrl+Alt+F1 and log in.

  2. Install compizconfig-settings-manager by running

    sudo apt-get install compizconfig-settings-manager
    
  3. Then run it by doing this:

    export DISPLAY=:0
    ccsm
    

    The first part tells the terminal which display you want it to load on (otherwise it won't have a clue).

  4. Press Ctrl+Alt+F7 (or Ctrl+Alt+F8 sometimes) to get back to the graphical display where there should be a CompizConfig Settings Manager screen sitting there.

  5. Find the Unity plugin. Enable it. CCSM

  6. Everything should spring into life but if it doesn't, you might have to restart. You can do that by going back to tty1 and running sudo reboot.

If unity still does not load try:

dconf reset -f /org/compiz/
unity --reset-icons &disown

Reboot if it doesn't work right away.

For 11.10 And Older

If you hope into a TTY (Ctrl+Alt+F1 through F6) and run:

DISPLAY=:0 unity --replace

It will reset Unity back on TTY 7 (Ctrl+Alt++F7).

You can also try just:

DISPLAY=:0 unity

But that won't work if a windows manager is already running on display 0 (it will give you an error, just use unity --replace in that case).

If Unity absolutely refuses to restart try this:

Install gnome-panel:

sudo apt-get install gnome-panel

Than run it on display 0:

DISPLAY=:0 gnome-panel

You should then have Gnome 2 style panels on your desktop, which you can use to logout.

Hybrid Graphics

Some very useful information and further reading for hybrid graphics users can be found here.

Once GPUs are configured appropriately for 3D acceleration and OpenGL you can:

  1. Install Nvidia drivers from https://edge.launchpad.net/~xorg-edgers/+archive/ppa:

    sudo apt-add repository ppa:xorg-edgers/ppa
    

    or:

    I would really prefer the stable PPA, but it does not seem to have packages for 13.04 yet. Update: these seem to be available as of Sep. 25. I would install this stable PPA - you can try but I have not tested it.

    The Ubuntu-supplied Nvidia drivers were already installed and I simply installed from this PPA by adding it and doing a package update using update-manager.

    sudo apt-add repository ppa:ubuntu-x-swat/x-updates
    
  2. Install Bumblebee from https://launchpad.net/~bumblebee/+archive/stable

    UPDATE: As of Oct. 6, ppa:xorg-edgers/ppa seems to contain bumblebee as well. So if you install from this PPA, you might want to try skipping the addition of the Bumblebee PPA and installing it from here instead.

    If you chose the stable PPA in step 1, install the Bumblebee stable PPA as follows:

    sudo apt-add-repository ppa:bumblebee/stable
    
  3. UPDATE: After adding the PPA(s), update your package lists:

    sudo apt-get update
    

    If you already had nvidia drivers installed from Ubuntu's standard repositories, simply upgrade to get the new version from the repository chosen in step 1:

    sudo apt-get upgrade
    sudo apt-get install bumblebee
    
  4. Perform the following commands to 'repair' Unity (from brandon-bertelsen's answer to Unity doesn't load, no Launcher, no Dash appears):

    dconf reset -f /org/compiz/
    unity --reset-icons & disown
    
  • In 14.10: unity --reset-icons &disown gives me stop: Unknown job: unity-panel-service // start: Unknown job: unity-panel-service // compiz (core) - Info: Loading plugin: core // compiz (core) - Info: starting plugin: core ... and no further action. Alt-F7 takes me back to graphical where I have a side menu but no "start" menu (nothing on the top menu -- no connectivity icon, power icon, etc. -- back to tty1 gives me screens and screens of information ... reboot and I am BACK IN BUSINESS! THANK YOU FOR YOUR MAGIC VOODOO – JeanSibelius Mar 7 '15 at 14:01
  • 3
    Your "For 12.04 and newer" section does not work on Ubuntu 16.04. – Luís de Sousa Aug 2 '16 at 18:31
  • apt-add-repository ? - missing – Kalpesh Soni Aug 15 at 16:14

The easiest way to do this is to press Ctrl+Alt+T to get a terminal and then issue:

rm -rf ~/.compiz-1 ~/.config/compiz-1

and your unity session will come back before your eyes..

This technique is better than re-launching ccsm, because you can get into OP's error condition without even accidentally de-selecting unity in ccsm; you can get it simply by accidentally pressing the "preferences" button in ccsm.

  • 2
    guess you mean .config/compiz-1 – matteo Oct 13 '13 at 21:01
  • I cannot use ctrl-alt-T – jimifiki Dec 18 '14 at 4:12
  • 1
    @jimifiki: press 'crtl' + 'alt' + 'f1' and then do what achiang suggested. though personally I'd move them out of the way incase you find more problems. – isaaclw Dec 19 '14 at 19:40
  • @isaaclw I did what suggests. Nothing has changed. Remarkably the guest session works normally. – jimifiki Dec 29 '14 at 15:05
  • 2
    For my Ubuntu 16.04, the relevant files to remove were in .cache, not .config. So rm -rf ~/.cache/compizconfig-1 worked for me. – tparker Mar 14 at 17:54

I had this problem too. I solved it with deleting the content of the ~/.config/compiz-1/compizconfig file and relog.

rm -rf ~/.config/compiz-1/compizconfig/*
  • 1
    didn't work for me, pretty much as everything else on this page – matteo Oct 13 '13 at 21:01
  • 2
    Yes! Thank you, It worked! I have Ubuntu 16.04 installed in VirtualBox and after one of the updates I got this problem. This is the only solution that worked for me! Oh, and don't forget to restart after applying this fix. – informatik01 Jul 26 '16 at 7:14
  • 2
    Does not work on Ubuntu 16.04. – Luís de Sousa Aug 2 '16 at 18:38
  • 2
    Did not work for me on 16.04 – 43Tesseracts May 16 '17 at 21:18
  • 2
    For my Ubuntu 16.04, the relevant files to remove were in .cache, not .config. So rm -rf ~/.cache/compizconfig-1 worked for me. – tparker Mar 14 at 17:55

I have had exactly the same issue.

If you have Compiz Config Settings Manager installed it may be that the Unity Desktop Plugin is disabled.

Log in to a Unity 2D desktop and check that it is enabled in CCSM like this,

CCSM

Unity Shell will not load in the default desktop if the tickbox is not checked and you will get the session in your picture.

Developers are always fixing bugs, so an alternative is to wait, and to follow progress on bug fixing (subscribe to Unity development in Launchpad).

  1. Press Ctrl+Alt+F2.

  2. Log in.

  3. Run sudo shutdown -r now in a terminal.

  4. At the login screen after your system restarts, choose Unity 2D (for now) by right-clicking the sprocket icon.

  5. Wait for a fix for Unity 3D/Ubuntu 11.10 (e.g. a week).

  6. Update your system to get the fix; in a terminal type sudo apt-get update && sudo apt-get upgrade.

UPDATE: I was able to resolve this by using ccsm, from Unity 2D login.

(This is adapted from this Ubuntu Forums post.)

  1. At the login screen, select Unity 2D and login.

  2. Install ccsm (CompizConfig Settings Manager) by running in a terminal: sudo apt-get install compizconfig-settings-manager compiz-fusion-plugins-extra.

  3. Start ccsm, and select the category Desktop. Enable the Ubuntu Unity Plugin; if asked to resolve conflicts, select the MIDDLE button for all conflicts. Close ccsm when done.

  4. Restart, select Unity (3D) and login.

I have an Asus U36SD using an "Optimus" (Intel + Nvidia GPUs) set-up. I had Ubuntu 12.04 working just fine, but upgrading to 12.10, this problem appeared and persisted in 13.04. I have managed to fix it trough the following steps:

  1. Install Nvidia drivers from https://edge.launchpad.net/~xorg-edgers/+archive/ppa.

    OR:

    I would really prefer the stable PPA at https://edge.launchpad.net/~ubuntu-x-swat/+archive/x-updates, but it does not seem to have packages for 13.04 yet. Update: these seem to be available as of Sep. 25. I would install this stable PPA - you can try but I have not tested it.

    The Ubuntu-supplied Nvidia drivers were already installed and I simply installed from this PPA by adding it and doing a package update using update-manager. UPDATE:

    sudo apt-add repository ppa:xorg-edgers/ppa
    

    (what I did) or:

    sudo apt-add repository ppa:ubuntu-x-swat/x-updates
    

    (stable release for 13.04 too now - not tested by me).

  2. Install Bumblebee from https://launchpad.net/~bumblebee/+archive/stable

    UPDATE: As of Oct. 6, ppa:xorg-edgers/ppa seems to contain bumblebee as well. So if you install from this PPA, you might want to try skipping the addition of the Bumblebee PPA and installing it from here instead.

    If you chose the stable PPA in step 1, install the Bumblebee stable PPA as follows:

    sudo apt-add-repository ppa:bumblebee/stable
    
  3. UPDATE: After adding the PPA(s), update your package lists:

    sudo apt-get update
    

    If you already had nvidia drivers installed from Ubuntu's standard repositories, simply upgrade to get the new version from the repository chosen in step 1.:

    sudo apt-get upgrade
    

    Install Bumblebee

    sudo apt-get install bumblebee
    
  4. Perform the following commands to 'repair' Unity (from brandon-bertelsen's answer to Unity doesn't load, no Launcher, no Dash appears):

    dconf reset -f /org/compiz/ 
    unity --reset-icons &disown
    
  • I just needed to perform the last step of your answer because I have the nvidia card deactivated in bios and never used it but the dconf reset worked perfectly. Thanks! – Daniel W. May 7 '13 at 11:12
  • 1
    Thank you! This happened to me just now after an update and the last step was enough for me too. – TenLeftFingers Jul 6 '13 at 1:15
  • how do you install that stuff from those links while having no launcher and being even unable to move windows around? I've tried skipping that step but it does not work for me. Can you give command-line instructions for adding those ppa's and installing those things? – matteo Oct 13 '13 at 20:46
  • I added some details above - hope it helps. – Thomas Arildsen Oct 14 '13 at 20:42

The original poster of the duplicate question, solved in editing his own question:

Solution found : Delete .Xauthority in my home (or rename it)

  • This is so great! – GhostCat Sep 1 '16 at 3:55

For 13.10:

Just to insure everything is installed:

sudo apt-get install --reinstall unity ubuntu-desktop

Next, reload everything:

dconf reset -f /org/compiz/ && unity --reset-icons &disown

I just tried this and it works!

Source:

https://askubuntu.com/a/204784/54037

If all else fails:

Remember, always make backups! However, sometimes a fresh install is good, reinstall Ubuntu?

  • The 'if all else fails' is a bit useless... see also: meta.askubuntu.com/questions/11710/… – Wilf Aug 11 '14 at 20:29
  • @Wilf Fresh installs are never useless. Most people have a poor install or simply mess up their installation. Time for refresh. – Jared Burrows Aug 11 '14 at 20:34
  • 1
    yeah, especially with upgrades... I have found that apt seems to have developed the knack of removing unity to to wacky interpretations for regular expressions (e.g. nuking webapps) - checking whether unity is installed/installing anything that is missing can then be helpful, – Wilf Aug 11 '14 at 20:44
  • This worked after a lightdm restart :D. Thank you, I tried dpk-reconfigure but looks apt-get --reinstall is better in this case. – Thomas15v Feb 23 '15 at 18:28

This happened to me as well in Ubuntu 16.04 after an upgrade of unity and compiz packages. None of the above worked.

The only way I found to have launchers and dashes back was to remove (while NOT logged into Unity) the directory .cache in my home.

  • 4
    Thanks, having tried so many other solutions in vain (ccsm, resetting, deleting config dirs etc.), this solved the problem for good! – fuenfundachtzig Sep 27 '16 at 21:02
  • This is often the case if you jiggle with drivers, GPU's and all... deleting .cache will do the job. – stamster Feb 26 at 1:44
  • Worked for me too (Ubuntu 16.04). Something upgraded when I last shut my machine down. When it started back up, Unity wasn't loading. I tried many of the steps above, and none of them worked. This simple step of deleting ~/.cache did the trick. Thanks! – Anthony V Mar 16 at 18:20
  • This happened to a friend running 16.04. I resolved it by upgrading her to Ubuntu 18.04, using the new Gnome desktop instead of Unity. – Mark Stosberg Mar 28 at 11:59

It seems there's a problem with 12.04 Unity 3D and the current Nvidia drivers.

See this post (Unity 3d no longer works after installing 12.04) for details of how to work round the problem.

I have a 32 bit Pentium 4 3.06 GHz Compaq D520SFF, with an Nvidia GeForce 6200, running kernel 3.2.0-24-generic-pae, and had exactly the same problem (2D works, 3D doesn't), and downgrading the Nvidia drivers got 3D working for me in a couple of minutes.

  • 1
    i did almost all the answers in this community related to my issue..please give me some thing work... – Yahya May 1 '12 at 4:38
  • Almost all is a vague phrase.... Have you actually tried downgrading the NVidia drivers from 295.40 to 295.33 as described in the post? – Heimdall May 1 '12 at 7:13
  • i did all described by the post nothing happened... – Yahya May 1 '12 at 11:33

For the icons, it is due to Nautilus. Write nautilus & in a terminal, do not close it, and the icons will be back.

EDIT 10/10/2013: for Nautilus you can also type Alt + F2 to open Unity command line prompt and write nautilus in the global search/prompt CLI. A file explorer will open. You can close it if you want.

I had a similar problem:

unity with 14.04 in combination with IBM Notes9 resulted in some strange behavior (mouse clicks would stop working). My workaround for that was to open a terminal and restart unity by typing unity &.

The last time I did that, it totally corrupted unity - the no dash, no launcher no nothing. I think I tried EVERY suggestion that is listed on this page - none of it did help.

But a coworker finally had the answer that worked for me:
I installed the unity-tweak-tool; than I ran unity-tweak-tool --reset-unity and rebooted.

Afterwards, unity was back alive. Obviously all prior configuration changes to unity were gone, but that is what --reset-unity is about.

And the big advantage of this solution: it requires you to only add a single package and to redo your unity config changes - but you do not have to reset compiz, install ccsm, or follow all the other lengthy activities.

Update:

the other solution I find very helpful nowadays comes from here - the point: sometimes you have to remove (or even better: pull in a "working" backup) of your ~/.config/dconf/user file.

  • 1
    This is the only thing that worked for me! – sevenseacat Jun 25 '14 at 13:33
  • On Ubuntu 16.04 this brings back the launcher, but not the dash or desktop. And after rebooting everything is dead again, and you have to repeat the procedure. – Luís de Sousa Aug 2 '16 at 18:30
  • @LuísdeSousa Lets be precise here: that what you probably observed on your system. Thing is: it seems that there can be various reasons leading to such problems; and I found that using the tweak-tool can help. – GhostCat Sep 30 '16 at 7:28
  • @LuísdeSousa For the record; the other solution I found to unity-stuck/not there problems: remove ~/.config/dconf/user ... sometimes restarting unity helps, but sometimes I have to go in and delete that file. – GhostCat Feb 17 '17 at 12:58

If you hope into a tty (Ctrl+Alt+F1 through F6) and run:

DISPLAY=:0 unity --replace

It will reset Unity back on tty 7 (Ctrl+Alt++F7).

You can also try just:

DISPLAY=:0 unity

But that won't work if a windows manager is already running on display 0 (it will give you an error, just use unity --replace in that case).

If Unity absolutely refuses to restart try this:

Install gnome-panel:

sudo apt-get install gnome-panel

Than run it on display 0:

DISPLAY=:0 gnome-panel

You should then have Gnome 2 style panels on your desktop, which you can use to logout.

I find Unity to be really buggy on 13.04 with my Nvidia card.. YMMV.

I have had about 3 times where I needed the Ctrl+Alt+F1 to not loose work and it messed up... I have nvidia also. I would like to suggest this:

Ctrl+Alt+F1 (ok, blank screen) Type your login, hit Enter, then password (all in blank screen) type this now:

sudo startx -- :1

will have to type password again and Enter this will open a X session at Ctrl+Alt+F8 (will jump to it automatically) now create a new empty text file called runBash.sh, and type on it:

bash

save it, change its permissions to executable, and run it, you will get a truly relieving terminal that makes you remember why Linux is good ! :D

after you finish, remember to Ctrl+Alt+F1, hit Ctrl+C (will end the new X session), type exit, Enter, will end the terminal (blank screen) session. if you think you missed typing exit, just hit Ctrl+C and type again, don’t do it too fast.

so you can improve it, make a script to let you type as little as possible, but anyway you will still have to type a lot while the screen is blank, but it is better than nothing :)

Still looking for definitive Ctrl+Alt+F1 proper solution Ubuntu 12.04 + nvidia.

  • hi again, I have ABSOLUTELY no idea why, but for some reason, after a system freeze (I was playing a 3D game in wine), I hard reset the computer, and from a sudden I have back my text terminal ctrl+alt+f1 (but my account become unable to login thru lightdm graphical login screen, despite I still can login thru text terminal, I continue this affair on this thread: askubuntu.com/questions/133733/…) – Aquarius Power May 28 '12 at 1:33
  • By "blank" screen, do you men "black" or "empty"? Unless your video shows terminals in reverse video, the background is black and thus it looks much more like a black screen. Also, most often, after the Ctrl+Alt+F1 you have to hit Alt-F1, Alt-F2... to Alt-F6 to reach a terminal. – Alexis Wilke May 21 '16 at 20:15
  • @AlexisWilke so long time... but.. as I remember, blank in a sense that you are unable to read things on screen. May be this was a secondary problem happening here also. – Aquarius Power May 22 '16 at 1:54

If you use an acceleration graphics card alongside the default graphics card, it's possibly due to the installation of their drivers. A few updates of acceleration graphics cards drivers in systems that have two graphics card tend to present unstable behavior in some systems. I have an Nvidia card and an Intel card. It used to happen with me when I installed Nvidia drivers. Launcher and panel would disappear from the the desktop. If you use an Nvidia card, installing Bumblebee could be a temporary solution: https://wiki.ubuntu.com/Bumblebee

  • I've got a ThinkPad T430u with a dedicated nvidia card but I disabled it in the BIOS and never installed any extra drivers or added 'x-swat' or edgers ppa since the intel HD4000 worked perfectly out of the box and I had been running this setup without problems for about 2 months – Daniel W. May 1 '13 at 16:03
  • The behaviour of my Asus U36SD seems to confirm that it is a problem with the combination of two GPUs (Intel/Nvidia). I will post an answer explaining how I fixed it. – Thomas Arildsen May 2 '13 at 10:05

The first answer works fine, except I needed to install Unity itself:

sudo apt-get install unity

then run:

ccsm

and enable Unity :)

  • forget to mention it's happens on my new ubuntu 13.10, never before! – sobi3ch Nov 26 '13 at 1:24

I had pretty much the same problem under 12.04. Unity was slow with my aged GPU, so I was using Unity 2d as my desktop for months. For no apparent reason, it suddenly refused to display launchpad and title bar (for all users). Reenabling Unity in CCSM as sugggested here was part of the solution, but none of the other measures suggested here, there or in several other related threads, including, but not limited to:

  • Reinstalling unity

  • Reinstalling ubuntu desktop

  • Removing all relevant (e.g. compiz, gconf, etc.) configuration information

helped me to completely resolve these symptoms under 12.04 (64 bit).

unity --reset

would not work for me. After delivering a variety of error and information messages, it would always hang at:

Setting Update "run_key"

as shown in the log posted in the thread titled "unity has vanished" for unity run with no arguments.

I noticed that the error message delivered by:

/usr/lib/nux/unity_support_test -p

was similar to some of the errors reported by unity --reset:

error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory.

After extensive searching, I found the following solution:

  • Get the path of libGL.so.1 by using the command locate libGL.so.1.

  • Add a link to the library in /usr/lib/ as shown in the following example:

    sudo ln -s /usr/lib/i386/mesa/libGL.so.1 /usr/lib
    

    (courtesy of J.D. Bartlett)

  • Restart the computer.

This not only allowed both unity_support_test-p and unity --reset to run, it also allowed Unity 2D to start. I have no idea what caused my problems, but since creating the links above (several weeks now) I have had no further problems.

When I accidentally upgraded from 12.04 LTS Ubuntu to 13.04, I too had to face the same issues such as missing side menu bar, no window options, not being able to switch between applications (alt-tab) and I couldn't even drag windows on the screen. After following so many options I ended up with the following set of commands to fix these issues.

sudo apt-get remove aspell #may not be relevant
sudo apt-get remove dictionaries-common

reboot (you can use sudo reboot)

sudo apt-get install compizconfig-settings-manager
sudo apt-get install dictionaries-common
sudo apt-get install lightdm

reboot (you can use sudo reboot)

dconf reset -f /org/compiz/
unity --reset-icons & disown

I actually removed aspell because of conflicting dependency. This might not have any correlation between this issue. I think re-installing lightdm and resetting compiz helped me in fixing this.

It happens when you login with another tty and try, as the same user, to start X (with startx or initx) .

For example, Ubuntu runs in tty7. With Ctrl+Alt+F1 tty1 opens. Log in as the same user, and run startx. Go back to tty7, logout and login. You only get the desktop wall paper.

To solve the problem, choose tty1, login, remove the .Xauthority file in your home directory, logout, login. Solved.

  • didn't work for me (also, I hadn't ever started X from another tty) – matteo Oct 13 '13 at 20:53

I had the same issue after doing sudo apt-get install kubuntu-desktop which broke my lightdm install for some reason. I'm running 16.04 here.

Press ctrl - alt - F1 to get to the terminal, then:

sudo service lightdm stop
sudo apt-get remove lightdm
sudo apt-get update && sudo apt-get install lightdm
sudo reboot

That fixed it for me after hours of pulling my hair out.

Worked for Ubuntu 16.04:

I reset compizconfig by removing its cache (actually the command makes backup, so it can be restored).

Perform the following commands and logout afterwords:

mv ~/.cache/compizconfig-1 ~/.cache/compizconfig-backup

setsid unity

Attention: This removes your custom Unity setup.

I am having the same issue, and solved by following using pycharm's terminal.

 - Go to my-computer -> user -> share ->  
 - open pycharm and its terminal
 - sudo apt-get update
 - sudo apt-get upgrade 
 - sudo apt-get install --reinstall ubuntu-desktop
  • 1
    You don't need pycharm to fix unity. Ctrl+Alt+F1 should always give you a terminal. – Tim Tisdall Oct 5 '16 at 11:56
  • this worked for me in 16.04 – byronyasgur Jan 26 '17 at 2:31

Apparently, unplugging my second monitor was the fix, and then I was able to install and update the correct drivers.

I tried many of the solutions mentioned in this thread as well as others. Finally this worked for me:

dconf reset -f /org/compiz/

then

setsid unity

Thanks everybody for contributing.

Today I've encountered situation where user of my script has decided to launch it by placing the call to script into his $HOME/.profile file. As a result , Unity couldn't launch.

Scripts by nature are sequential, so .profile basically was waiting for the script to finish , and Unity couldn't start if .profile didn't finish running.

I've done the same thing,called the script from .profile, and received the same result - my login screen wallpaper stayed there, no dash or launcher appeared, could not right click on desktop or perform any action other than login to TTY1.

The solution was to remove appropriate line from the .profile. It's possible to detach a command from .profile using the ampersand, <command> & form , but the problem is that every time user opens terminal or logs in to TTY, a new instance of that command is spawned. Hence, I would strongly advise not to launch any programs from .profile unless you know what you're doing.

Link to original script and discussion here: https://askubuntu.com/a/739631/295286

I had this Problem, I tried a load of things and even enabled unity, but nothing worked. First, you need to open TTY (ctrl+alt+F1) and login. Now use

    env DISLAY:=0 gnome-terminal        

Close TTY with ctrl+alt+F7, then use (in terminal)

dconf reset -f /org/compiz/

After that, use

sudo reboot
  • Thanks!! That worked for us finally. We were able to open guest session but not the regular user. – radbrawler Feb 8 '17 at 6:49

protected by Community Apr 16 '12 at 17:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.