27

I installed thunar yesterday but on starting up this morning, I found that all of the folder icons had vanished. I'm using i3wm (but the icons were visible in i3 as of yesterday). Any idea why they might have disappeared or how I could retrieve them?

Thanks.

Screenshot

  • In fact what happened was that I had removed unity and dependent packages. The icons went with it. – UtterlyConfused Jan 20 '15 at 20:02
26

Try installing gnome-icon-theme-full.

  • 4
    Are you sure that's right? The OP is using Xubuntu and Xfce. – Seth Feb 13 '13 at 19:18
  • I don't see how to post this as a response to another answer. Just wanted to confirm that I use Fluxbox as my WM, and the solution of installing gnome-icon-theme-full works great. I made sure that it did not install excessive dependencies before I hit 'Y'. – sorak Feb 28 '13 at 1:32
  • I had this issue with xubuntu and this fixed it – Adam Bell Apr 30 '13 at 22:11
  • Why not xubuntu-icon-theme? – qed Nov 21 '13 at 13:47
  • @Seth this answer seems to work, after I installed that package (no other dependencies/recommended/suggested were installed) almost all the icons were there, including those inside the applications menu – Ferrybig Aug 31 '17 at 20:03
17

I'm on Xubuntu 12.04 and using awesome WM. I can confirm that installing gnome-icon-theme-full partly solve the problem. I can also confirm it just install one single package without any excessive dependencies. But it has some side effects. It replaces some Xubuntu customised icons and makes them look weird. So I deleted it. After doing some search, I find another solution here works better. Just install lxappearance and choose a icon theme. You can also change your gtk theme using it. It's weird that xfce4-settings-manager doesn't work under awesome.

  • 1
    easiest method so far. – Suhaib Oct 27 '14 at 16:48
7

I run i3 on Xubuntu 18.04, this worked for me:

  1. Create/modify the file .gtkrc-2.0 in your home directory
  2. Add/edit the line gtk-icon-theme-name="gnome", change gnome to your desired icon theme.

This can be done by executing echo "gtk-icon-theme-name=\"gnome\"" >> ~/.gtkrc-2.0 in your terminal.

Credit: https://www.linuxquestions.org/questions/slackware-14/no-icons-in-thunar-when-running-out-of-xfce-4175469261/#post4988339

  • And instead of "gnome" you can use any of the folder names from here: /usr/share/icons/ . – Felix Sep 16 '18 at 20:47
6

Try setting some icon theme with, for example, xfce4-settings-manager and running xfce4-settings-helper before starting Thunar. It helps with awesome wm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.