I have used the program "Universal USB Installer" to 'save' Ubuntu on my USB stick. So far - good.

When I boot it, I get these options

enter image description here, but on a totally black screen and I can't use them.

I choose to install, then it goes to completely black screen and nothing happens. No install, nothing.

I restart and try again - same thing.

Can someone tell me how to properly install it? I'm trying to install desktop version 12.04 amd64.

PC Specs:

  • Processor - Intel Core i3-2130
  • Memory - 4 GB RAM
  • Current OS - Windows 7 x64
  • So did you tried the nomodset option too . – atenz Aug 8 '12 at 18:14
  • 1)Did you download the 64bit .iso? 2)It may be corrupted so I'd download it and burn it again or try from another source – dlin Aug 8 '12 at 19:09
  • Yes, I tried with the 64bit version. I've tried from another source too, the problem is not in it..... Now I tried using wubi to install Ubuntu and when I got to boot manager & choose Ubuntu it gave some errors and didn't load.. (couldn't see the errors). – Marina Aug 8 '12 at 19:37
  • @tijybba - I couldn't see those options :) I just see "Try Ubuntu without installing" and the others on a black screen, nothing else. I tried burning it to my USB stick again now and it didn't even load that. – Marina Aug 8 '12 at 19:39
  • Did you solve this problem? – Mina Samy Jan 1 '17 at 19:51

Just download the tool from here.

Use it to write the ISO image to your USB stick. The USB stick will then be bootable.

After that you can boot from your USB stick and "Install Ubuntu" or "Try Ubuntu without installing."

Just select USB Hard Disk in the BIOS boot menu. (Very old computers' BIOSes might not support this.)

| improve this answer | |

Sounds like a video card driver issue. Try changing the kernel boot options from quiet splash to quiet splash nomodeset.

If this works for you, after you install Ubuntu, you'll have to set it again to boot your fresh Ubuntu install. Once you're in, get an internet connection(using an ethernet cable if WiFi doesn't work) and install proprietary drivers.

Read more: http://blog.js-development.com/2012/01/help-ubuntu-1110-wont-boot.html#ixzz22zGQx3lo

| improve this answer | |

This is caused of Corrupted .iso that you written on USB. Choose "Check disc for defects" Option from menu. You should have checked md5sum after downloading ubuntu image file.

| improve this answer | |

I recently did a 64 bit install from usb and noticed some problems:

  1. From the Try Ubuntu / Install Ubuntu screen, if Install is selected, things hang at the color-cycling dots. Esc will bring up the error text -- no media found for /dev/sdb (or ...sdc if I have another usb target present).
  2. The "Try" option gets to the desktop, so click on the install icon there. Note, I always type something on the "manual" screen with the little keyboard/person icons to avoid some video issues.
  3. Installing to another USB worked, except the grub boot block did not seem to get installed. I had to explicitly install grub to the target, which then worked. If you still have boot problems, check the grub boot paragraph for wrong devices -- USB installs still are off by one (too high) on the initial grub setup because the USB install media gets removed before booting the target. Instructions for editing grub are on screen. Run update-grub at the first successful boot to fix the problem (by using UUIDs instead of actual devices).
| improve this answer | |

Had the same issue on my brand-new Lenovo t450s .

It turned out, that my 16GB USB-stick was the culprit.

Using another usb stick worked.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.