I am using Unity on Ubuntu 12.04. For some time now, the Applications lens is completely empty when I open it. If I search for any applications from the Home or Applications lens, no results show up. I have tried killing and launching the Applications lens as suggested at Launchpad, but it did not work. How can I get the applications lens to work again?

  • 2
    A screenshot could be useful. Also try unity --reset and reboot. – atenz Aug 8 '12 at 18:15
  • Thanks! Using unity --reset worked. Please post it as an answer so that I can accept it. – Aaron Hill Aug 8 '12 at 18:36
  • careful with that unity --reset. It killed my launcher, panel and window surrounds. – comrademike Jan 9 '14 at 13:49
  • possible duplicate of Dash search gives no result – JoKeR Jun 28 '15 at 15:03

In the terminal try

unity --reset

and reboot to see the changes.

As far as the mentioned bug is concerned ,it was affecting the unity-lens-applications-5.8.0-0ubuntu1 (precise) package and current version stands at unity-lens-applications (5.12.0-0ubuntu1) .

It also states that fix is released so please update your system , if already up-to-date than ignore this.


I know this has been fixed for the OP, but I had the same problem and it wasn't solved with the suggestions above. In the end I fixed with:

rm -r ~/.cache/unity && unity --replace &

My software centre was also broken and that was fixed with:

rm -r ~/.cache/software-center

From other posts I think the two may be connected hence posting both solutions together here for future searchers.


You can also use the command

 unity --replace

and you don't need to reboot (more convenient). This command restart both Unity and Compiz and clean all the GUI like if she was restarted.


I am not sure but I think at least one of the previous fixes changes unity settings, setting them to default settings. This may be necessary, but sometimes just a restart of unity has worked for me. From another askubuntu site I found that typing the following in a terminal will restart unity and recover my lenses:

unity &> /dev/null & disown

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.