76

I am using Ubuntu 12.04. Recently, the font size for all of my TTYs became much larger. How can I change the font size back to the default?

  • You mean the gnome-terminal or the TTY accessed with Ctrl+Alt+F1, etc.? – ish Aug 8 '12 at 0:35
  • 6
    I mean the TTY. – Aaron Hill Aug 8 '12 at 0:44
  • This is a very useful method for new XPS13 which have a very high resolution, resulting in tiny fonts. In fact this page linked to from an xps repository on github – username Oct 31 '19 at 13:15
118

To adjust the font/font-size used for the TTY, run sudo dpkg-reconfigure console-setup, which will guide you through the steps to choose a font and font-size:

  1. Choose the default UTF-8, and press Tab to go highlight OK and then press Enter to go to the next step. (You can press it again and highlight Cancel to go back.)

    enter image description here

  2. Choose the default Combined - Latin, ... option ("Latin" includes the English alphabet) and proceed to step 3:

    enter image description here

  3. Select the font - be sure to read the notes above on the visual effect different fonts can have:

    enter image description here

  4. Select the font size:

    enter image description here

  5. Now you will exit console-setup; as the displayed message says, the new settings will be effective after reboot. To apply immediately, open a TTY and run setupcon.

| improve this answer | |
  • Running this command first prompts me to select an encoding, where I choose UTF-8. On the next screen, where I am prompted to select a character set, there is no option for any kind of English character set. – Aaron Hill Aug 8 '12 at 0:55
  • 5
    You should be fine with the Combined - Latin... default. "Latin" is the English character set. From wikipedia: The term Latin alphabet may refer to either the alphabet used to write Latin (as described in this article), or other alphabets based on the Latin script, which is the basic set of letters common to the various alphabets descended from the classical Latin one, such as the English alphabet. – ish Aug 8 '12 at 1:01
  • 6
    @qed, in step #3, if you select Terminus instead of Fixed, there are larger font sizes to choose from. – Afilu Jul 18 '17 at 21:41
  • 2
    What if I want to use another font I downloaded instead of the ones listed? – tyjkenn Aug 30 '17 at 17:16
  • 3
    @tyjkenn You can only use bitmap fonts so if you want to use your own font then you have to find a bitmap version of it. For example the package fonts-ubuntu-font-family-console contains the bitmap versions of the ubuntu font-family. – hexman Dec 13 '17 at 14:48
2

Since the other answers did not work for my HiDPI display to increase the font size, after some research I found https://askubuntu.com/a/1134018/73759 to be working.

Edit the file /etc/default/console-setup

sudo nano /etc/default/console-setup

and change the values for font type and font size to

FONTFACE="TER"
FONTSIZE="16x32"

Save the file and apply the changes with

sudo update-initramfs -u

On the next reboot you will have a much larger font in your TTY.

I know this is not the answer to the specific question above but the title just says "change the font size" and this is the top search result on google, so I hope I can help some people here.

| improve this answer | |
  • This should work in the second half of the boot and the virtual consoles accessible via Ctrl+Alt+[F1-F6]. Same as unix.stackexchange.com/questions/49779/… – Cees Timmerman Feb 10 at 11:52
  • man setupcon informs, or suggests, that one could also customize ~/.console-setup and not intrude in the system-wide default settings. – XavierStuvw Mar 27 at 15:39
1

Using GRUB_GFXPAYLOAD_LINUX

First, install xrandr and run it:

$ sudo apt-get install xrandr
$ xrandr

The available screen modes are listed.

Now, edit /etc/default/grub:

$ sudo nano /etc/default/grub

Assuming a previously unedited file, make the following changes:

The variable GRUB_CMDLINE_LINUX_DEFAULT should contain at least nomodeset, perhaps in addition to quiet and splash on desktop systems.

GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"

On server systems, uncomment GRUB_TERMINAL=console to see more messages passing during boot before entering in the graphics console.

Leave this line as a comment:

#GRUB_GFXMODE=640x480

At the end of the file, add a line:

GRUB_GFXPAYLOAD_LINUX=1280x1024x16

or replace the value by any other (comma separated) mode(s) that is(are) supported by your hardware. The values text, keep, auto, vga and ask should also work.

Finally, after saving the edited /etc/default/grub with Ctrl+O and exiting it with Ctrl+X, issue the following commands:

$ sudo update-grub
$ sudo reboot

This answer will also work to decrease the resolution and/or refresh rate or frame buffer frequency on down-clocked systems. CRT monitors typically show flickering stripes when the refresh frequency is too high.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.