I have installed Gnome 3 on Ubuntu today following this guide. All worked well and I have installed the extensions mentioned without problem.

However, after logging out and in, all extensions were gone. Going to the Gnome extensions website, I saw that all my extensions were outdated and that I could install only one other extension.

I'm rather new to Ubuntu and completely new to Gnome. I don't even know how to check my own version (there's no mention of Gnome in System Information) - I reasoned maybe I'm using an outdated version, even though apt-get update/upgrade/dist-upgrade does not upgrade anything or solves the problem.

How do I get things back working? I've uninstalled all my extensions, but that didn't do the trick, either.

Update: I tried to install the one extension the gnome website shows as valid, but nothing happens; same when trying to install 'outdated' extensions. I see the popup, choose install, nothing happens.

  • To see the installed gnome version post the output of gnome-shell --version . – atenz Aug 7 '12 at 16:32
  • $ gnome-shell --version GNOME Shell 3.5.4 – Raf Berkvens Aug 7 '12 at 17:14

I know this thread is a bit dated now, but I thought it worth mentioning that I had a similar problem to Raf, and in summary I think it has been solved by the following:

  1. Purge the testing repositories (ricotz and gnome3-team)
  2. Purge gnome-shell
  3. Purge gnome-shell-common (this was my biggest problem)
  4. Reinstall gnome-shell (after apt-get update)

Credit belongs to, and more detailed information can be found at, this thread: http://ubuntuforums.org/showthread.php?t=2009222


If you have installed GNOME 3 from above mentioned page repository, you most probably selected the Quantal repository or you are using Ubuntu Quantal under development release.

As per mentioned gnome-shell version 3.5.4 you are actually using a newer version yet to be released in stable repository for Ubuntu 12.04 Precise.

You are most probably using Ubuntu Quantal quetzal gnome-shell package .

Since currently in active development , no extensions are being ported or developed for 3.5.4 unstable release .

My guess, wait for stable release ought to be announced as 3.6 in October later this year and consequently in Ubuntu Official stable source.

As per this page it states GNOME 3.5.4 as unstable release

Remember that 3.5.x is a development release and it should NOT be installed on production machines. It is intended to be used for testing purposes only.

To revert it back as per this answer

sudo apt-get install ppa-purge
sudo ppa-purge ppa:gnome3-team/gnome3

To install Gnome 3.4

 sudo apt-get install gnome-shell

To remove the Gnome 3 PPA open software sources from Dash or through update manager in settings menu , then go to as image and remove or delete the gnome 3 ppa listings manually ( i don't have it :P ). Then do sudo apt-get update && sudo apt-get upgrade and install gnome shell as above command.

enter image description here

  • Thank you, this is most likely true, however unintentional. How can I revert to Gnome 3.4.x? – Raf Berkvens Aug 7 '12 at 17:48
  • Apt-get automaticaly selects version 3.5.4. I removed my version, but can't select the stable version. What to do? – Raf Berkvens Aug 7 '12 at 18:16
  • Edited the answer , please comment if this worked or if any encountered errors :) – atenz Aug 7 '12 at 18:19
  • Performing the suggested actions yielded a long list of libs that were removed, even as far as Rhythmbox that was removed, but trying to install gnome shell still gives:The following packages have unmet dependencies: gnome-shell : Depends: gnome-shell-common (= 3.4.1-0ubuntu2) but 3.5.4+git20120721.r1.dd80f390-0ubuntu1~12.04~ricotz1 is to be installed – Raf Berkvens Aug 7 '12 at 18:33
  • Thank you for your help, but after the ppa-purge I've lost so much stuff and I'm still unable to use Gnome, I think I'll resolve it by reformatting the harddrive. – Raf Berkvens Aug 7 '12 at 18:39

My solution (cause I was having the same issue after i upgrade to Gnome 3.6) was the following:

cd ~/.local/share/gnome-shell/extensions
mv <extensions you are having issues with> ~/Desktop

Then Alt+F2 then r and then enter (Note: this will restart your gnome session without you have to restart the computer)

Then you should be able to go into gnome extensions and install the new versions. I think there is some issue with properly being able to download and replace other older versions (especially if they were installed through other PPAs.

Remember you got to use Firefox also since Chromium is not always that reliable :(

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.