Day 4 of my purgatory.


  • Had problems with live CD at first, had to set the "nomodeset" option ... and then it worked fine.

  • Installed Ubuntu "Alongside" Windows XP from live CD (NOT wubi)

  • Upon reboot after installation, I get the BIOS ... and then a black screen.

  • If I hit shift after the BIOS screen I get text that says "loading GRUB ..", but then no GRUB ... just a black screen.

What I have tried to do:

  • Total re-installation ... 3 times now. Also tried with wubi, same black screen. Have gone back to the normal (non-wubi) install.

  • After installation, I tried re-booting the live cd ... and trying to change GRUB file using: sudo gedit /etc/default/grub ... to "nomodeset" and "timeout=10" ... but won't let me save my changes because I'm using the live cd "in memory" system and don't have permissions to the disks (I think). I tried logging in ... but it won't let me.

  • I then read many posts on this site. I'm stuck.

  • This morning, I ran the "boot repair disk". Results here: http://paste.ubuntu.com/1132333/

What I think is wrong:

  • Since I can get the live CD to run (perfectly) with the "nomodeset" option, I think all I need to do is get to GRUB to change that ... but I can't get to GRUB.

Appreciate any advice.


Day 5 ...

I downloaded "Super Grub 2 Disk" from: http://www.supergrubdisk.org/super-grub2-disk/

This looks promising.

I can boot the disk and it brings me to a GRUB program that allows me to:

1) Boot to Windows ... which works 2) Boot to Ubuntu ... which does NOT work

When I choose boot to Ubuntu, I get lines across the screen which is an obvious video card problem. Likely because I need to set the "nomodeset" option.

So, I attempted to use super grub2 to edit the grub file ... but it is TOTALLY different than the Ubuntu grub file ... and I don't know where to put the "nomodeset" option.

Still stuck ...

The bottom line is that:

1) I need to edit /etc/default/grub on sda(1) ... which is my boot drive ... to add the "nomodeset" option

2) To do that I need to get into grub ... but, I can't. Holding down shift just echo's "loading grub .." and then takes me to a black screen

3) I can boot to the live CD by setting nomodeset .... but I cannot access the hard disk as root ... I can't save my changes!

Can anyone tell me how to login as root for the filesystem from the live CD ... so I can edit the grub file on the HARD DISK ... and then run update-grub??

  • Is one supposed to edit /etc/default/grub or /boot/grub/grub.cfg?? – Akshit Baunthiyal Aug 7 '12 at 3:35
  • @AkshitBaunthiyal The former, then run sudo update-grub. – nanofarad Aug 8 '12 at 12:34

I had a similar problem a while back. This site will show you how to mount your install from a live CD. It does involve a lot of terminal work though:

How to Repair/Restore/Reinstall Grub 2 with a Ubuntu Live CD

Just a thought: don't follow all the instructions, they tell you how to remove and reinstall grub. If you just want to update it then only follow until you use chroot command and then run update-grub. Also make sure you use the correct partition.

Hope it helps.

  • Thks much. I got it to work. I used the "boot disk" and the clicked the "Advanced" from the "Fix it" screen. This gave me an option to add "nomodeset" to the installation i had on the Hard disk (not just what was loaded in memory). It worked. It was literally that easy! I'm up and running perfectly. Thks to all for help. – Pat Aug 8 '12 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.