I've been trying different configurations on awesome wm, but suddenly awesome stopped loading ~/.config/awesome/rc.lua on startup, and now only loads the default configuration at /etc/xdg/awesome/rc.lua.

I tried starting from scratch and copying the default to ~/.config/awesome, but that didn't seem to work. What can be causing awesome to stop loading my custom file? How do I even debug it? I tried awesome -k and it says everything's OK.


Ok, I figured it out. Debugged it using Xephyr.

Basically, I figured out that if there's an error in rc.lua, awesome rejects it and loads the default rc.lua from /etc/xdg/awesome. The trouble is, those errors don't often affect awesome -k, which still shows "Syntax OK!". Debugging using Xephyr, though, while a pain to set up, allows you to see more verbose error messages and pinpoint the problem. For me, I was missing a command that rc.lua refers to, a compositor. Installing the compositor fixed the problem.

  • do you mind sharing what the debugging revealed and what change you made to fix it ? – Joshua K Jan 22 '13 at 3:13
  • 1
    -1 as it doesn't explain in any detail. – l0b0 Apr 28 '13 at 9:34
  • I added more detail. – Jonathan May 9 '13 at 19:46

I had the same problem - to resolve, make sure you copy the entire contents of /etc/xdg/awesome - not just rc.lua!


mkdir ~/.config
cp -R /etc/xdg/awesome ~/.config

Now Awesome should take notice of your custom rc.lua.

  • Well, I'll be damned. My /etc/xdg/awesome only contains rc.lua. Now what? – frhd Feb 10 '15 at 17:45
  • What distribution? – Martin Konecny Feb 10 '15 at 18:06
  • Debian. Strange, awesome started using my config after I copied the default file. First time I copied, I modified it immediately, probably with some mistakes. Reloading didnt help. My guess is, awesome never accepted the config in the first place after seeing an error. Now, after using my previous config, it shows an error right after reloading. So maybe awesome initially needs to load a correct config in ~/.config/awesome/rc.lua when first providing a custom config.. – frhd Feb 10 '15 at 20:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.