I'm very new to Ubuntu so please bear with me. On the latest Ubuntu (12.04) I have set up thunderbird to read my Gmail account. I know there are browser addons that show you how many unread emails you have, but is there a way I can get this integrated with the Unity Mail icon on the top bar?


Not too sure why this is happening but can you please try setting Thunderbird as the default mail client.

You can access this in SETTINGS, then click DETAILS (in SYSTEM Section), then click on the Default Applications from the left list and change Mail section to Thunderbird.

Restart and check if it's working now.

Let me know if this worked as I don't have a sure answer but think it has something to do with default applications and would be nice to know.

  • Thanks for your answer but this doesn't work. Thunderbird was already set as default email client. I do get the on screen notification, but the mail icon remains the same – dukevin Aug 6 '12 at 6:51
  • I found an add-on that is required for the menu integration through Mozilla's website, check this addons.mozilla.org/en-us/thunderbird/addon/… . You could check if this add-on is present in Thunderbird and is enabled before trying to install it from their site. – exIT Solutions Aug 6 '12 at 7:09
  • This addon is already installed. – dukevin Aug 6 '12 at 7:12
  • Sorry this is all I know, I'll research it a bit and comment if I find anything – exIT Solutions Aug 6 '12 at 7:21
  • I know this might sound silly but can you click Edit > Preferences and in the General Tab check if it Show in the Messaging Menu is selected and for messages in all folders. – exIT Solutions Aug 6 '12 at 7:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.