so I've had problems with my wireless for a few months and now I really have to use linux to start programming again so I really need to get this fixed. I've been searching the web about my problem and appareantly the problem is the driver, so I'm trying to update it, but I can't seem to be able to do so.

I've been following this tutorial: https://unixblogger.wordpress.com/2011/10/18/the-pain-of-an-realtek-rtl8111rtl8168-ethernet-card/

But I'm stuck where I have to add the new driver to the kernel with the following command:

root@ubuntu:~/r8168-8.032.00# insmod src/r8168.ko

insmod: error inserting 'src/r8168.ko': -1 File exists

I've tried every "path" i can think of and I keep getting errors when I try to add the new driver. Any help will be greatly appreciated. Also, for more information about my computer (in case you need its necessary) everything's in this link: Centrino Wireless-N 1000 takes forever to connect and keeps asking for password

  • That first link is for an ethernet card not a wireless card, so updating that will not likely fix your problem. Maybe updating your original question with a link where you found out that it might be a driver problem might help? – Jorge Castro Aug 5 '12 at 22:57
  • I didn't really "find out" I supposed that could be the only problem left as I have tried almost everything and nothing seems to work. I'm starting to use Ruby on rails and it works better in linux than in windows, which is why now I really feel I should get this problem fixed :/ – waclock Aug 6 '12 at 1:03

I had similar problem with another Realtek adapter RTL8187SE (using r8187se as the default driver provided by ubuntu). Using the windows (xp) driver with ndiswrapper-1.58rc1 resolved the problem. I couldn't use the official ndiswrapper or ndisgtk (v1.57 from ubuntu repo). For details see the solution in this post.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.