I've done a fresh install of Ubuntu 12.04 64bit and I'm having major problems getting the display working.

Asus P8Z77-I DELUXE (latest BIOS, uses Z77 chipset)
Intel Core i5-3470 (onboard HD 2500 graphics)
Booting from an SSD.
A 1080p TV is hooked up to the onboard HDMI port.

The installer loaded but there were heavy graphic glitches inside any window so I couldn't read the install text. I managed to install by setting nomodeset.

Then on first boot I got a blank screen, only the cursor was visible and then the computer froze.

I then upgraded to the latest kernel (3.6-rc1), added the xorg-edgers repo and did a full dist-upgrade. So I should be fully up to date with the latest intel drivers. However this didn't make any difference.

If I set nomodeset then it boots to X and everything is recognised correctly in system info, but my monitor is listed as 'Laptop' and I'm limited to 800x600 and system info says 'VESA'. I'm guessing any hardware acceleration is disabled in this mode so that's no good.

If I don't set nomodeset then I either get a blank screen or a complete crash with a hung GPU.

james@Goon:~$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)

Trying to run Xorg -configure: http://paste.ubuntu.com/1130122/

Number of created screens does not match number of detected devices.

Some output from kern.log: http://paste.ubuntu.com/1130124/

I can post any other logs required!

There is also a similar question here: Graphics not working with Intel i5-3470

I also found a bug report: http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1031784

It claims to be fixed and I tried the PPA linked in comment #12, did the upgrades and rebooted.. and it still crashes.


To solve this problem:

1) Do a fresh install of Ubuntu 12.04, boot installer with the nomodeset option so you don't get a black screen during the install.

2) On first boot add nomodeset to the GRUB boot line, so you don't get a black screen while running for the first time.

3) Log in, open a terminal (ctrl-alt-T), and add Timo Aaltonen's patched hybrid xorg:

sudo add-apt-repository ppa:tjaalton/ppa
sudo apt-get update 
sudo apt-get dist-upgrade 

4) reboot. You shouldn't need nomodeset anymore.

Now it's working at 1080p. Now I have a problem with my terrible TV doing overscan on HDMI, but I'm happy with that for now.

  • worked also to resolve 3D acceleration not available (was entering in Unity 2D) – Pisu Jun 24 '13 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.