I am using 12.04. I was trying to install 'zekr' from 'zekr-1.1.0-linux_64.tar.gz' file I downloaded from http://zekr.org.

From what I could understand, it is a java program. I extracted the file and there was no installation instructions in it. I tried using ./configure after changing directory to extracted folder (I got this from some forum), but it says bash: ./configure: No such file or directory. And there was no file called configure in the extracted folder.

So please help me installing this software from this file. This file is not yet available in repository (though its previous version 1.0 does).

edit: This is the output of ls Al in he extracted folder. Sorry for late reply.

total 32
-rwxrwxrwx 1 faheem faheem 5628 Jul  5 21:27 build.xml
drwxrwxrwx 2 faheem faheem 4096 Jul 19 18:04 dist
drwxrwxrwx 3 faheem faheem 4096 Jul 19 18:04 doc
drwxrwxrwx 2 faheem faheem 4096 Jul 19 18:04 lib
-rwxrwxrwx 1 faheem faheem 4027 Jul  5 18:03 readme.txt
drwxrwxrwx 9 faheem faheem 4096 Jul 19 18:04 res
-rwxrwxrwx 1 faheem faheem 1166 Jul 19 17:59 zekr.sh

edit: Thanks everyone for helping. Anyway, I got from zekr official forum (google group) that what I had to do was run a file called zekr.sh in the extracted folder and it worked. Not exactly the way I wanted because I wanted to replace the current version permanently and to see it in application search. But it runs just fine for now. I created a shortcut of the file and put it in desktop for convenience.

  • faheem: When in the "extracted folder", what is the output of ls -Al? Please edit your question to include this information. – Eliah Kagan Aug 5 '12 at 2:33

Zekr version 1.0.0 is available in the Ubuntu repository. But, it is in multiverse section, so you need to enable multiverse repository first. See the below question to get help on enable multiverse repository:

After enabling multiverse, You can download and install Zekr on your PC. There is two way to install it:

Graphical way:

  • Install Zekr via the software center

    or clicking this icon

  • Zekr Install Zekr

Terminal way:

Open a terminal with CTRL+ALT+T and type these commands

sudo apt-get update
sudo apt-get install zekr

Note, first command is not required if you have updated your repository information recently.

I don't know the exact amount of change in Zekr version 1.1 from 1.0, but I think, installing 1.0 will suffice.

Hope this answer will help.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.