I am trying to get a PS3 Sixaxis controller to work with Ubuntu 12.04. The ubuntu wiki page for sixaxis says to install QtSixA, which I did. The issue now is actually using the controller. I installed "SuperTux 2" to test it out. Normally, SuperTux says there is no joystick. When I plug in the PS3 Controller, and press scan, it then displays all of the controls and their assigned buttons. I can then click on a action and it will prompt me to press the button I want to assign. The issue here that pressing buttons on the controller doesn't do anything. I can't assign any of actions to a button on the controller.

The same goes for PCSX. I can configure the controller, and select the Sony Playstation(R)3 Controller from the drop down, but when I try to assign a button, pressing buttons on the PS3 controller doesn't do anything.

On the web, I see tons of guides on how to connect with Bluetooth, but my computer doesn't have a bluetooth dongle, so I just want to connect via USB.

In addition, QtSixA can see the controller too. I can "configure default profile", which I have tried, but SuperTux 2 nor PCSX react any differently...

UPDATE: Following the Ubuntu Community Guide for Sixaxis guide, I tried sudo apt-get install libusb-dev libusb-0.1-4 xserver-xorg-input-joystick, and then compiled sixpair. Running sudo ./sixpair complains about enabling bluetooth, then SuperTux 2 can't find the controller anymore when I click scan.

After reading this article, I found out I have to press the PS button to get it working... Well, that worked fine for using the controller as a POINTER device. I can now make my mouse on screen dance using the analog sticks. I am still unsure of how to get it working with SuperTux 2 and PCSX though...

When I didn't have xserver-xorg-input-joystick installed, pressing the PS button caused it connect to the PS3 in the other room as controller 2. I am very confused about what is going on right now...


I have read something about it and I think it would be better to connect PS3 controller using bluetooth directly. Take a look of this.

I have read your limitations, and I still think that you need to use bluetooth. you could Buy a Bluetooth USB dongle, they are cheap (dealextreme.com/p/…).

  • Unfortunately, I can't use bluetooth, as I stated in my question. After browsing the article, I didn't see anything mentioning connecting bluetooth being better than USB. Maybe update your answer to include that? Thanks for the help regardless though! :) – drdrez Sep 3 '12 at 13:36
  • 1
    I readed your limitations, but I continue thinking you need to use bluetooth. Buy an Bluetooth USB dongle, it is cheap (dealextreme.com/p/…). – logoff Sep 5 '12 at 8:07
  • 1
    It would be better via Bluetooth as it would add the pc to the list of devices that the controller will auto search for when powered on (ie when it turns your PS3 on with the PS button) if that makes sense. – Phurl Oct 21 '12 at 20:53

I'm not sure if this will help, but when I set up my PS2 controller to play emulators I used jstest-gtk.

It took a little bit of time to get it set up between jstest-gtk and the emulator (I use ZSNES). After getting the controller to read properly through jstest-gtk I had to go into my emulator and assign all the buttons. (I had thought it would auto-detect the controller but it didn't.) It works great; I've not had any problems with it.

Like I said, I don't know if it will work for a PS3 controller though, but it might be worth the try.

  • I tested PS2->PS3 adapter (makes PS2 controller look like PS3 controller attached with USB cable) and arrow left (button 7) was missing analog axis according to jstest-gtk. Is this expected or possibly a bug jstest-gtk? – Mikko Rantalainen Apr 8 '17 at 11:20

I installed joy2key which can be installed directly from the repositories of debian, once installed before you run the program/emulator you run joy2key --dev /dev/input/[device number] --terminal, you need to configure the analog joysticks, (there is a way to avoid this later but I haven't look how to write the configuration file), then you are good to go, I use it with MAME and others, I still can't make it work with some snes emulators, hope this work for any who need to use it with the USB port.

  • I can confirm that on 14.10 joy2key works perfectly for usb only, you can use jstest-gtk to find out the device number as well as test functionality. – user276488 Jan 2 '15 at 1:40

You need to run this command in terminal:

sudo xboxdrv --detach-kernel-driver 

have a look at this.

  • While this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Thomas Ward Jun 21 '16 at 21:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.