My machine is always showing an hour ahead of the actual time. I am in Texas currently but the time never picks Day light savings. Any time I click on Set Time(Top Right Corner), my system just hangs right there. I have to turn off the machine each time. how do I fix this issue? alt text

This is what happens when I try ntpdate: still 1 hour difference.

ntpdate time.nist.gov 
13 Dec 21:44:37 ntpdate[3098]: bind() fails: Permission denied 
sudo ntpdate time.nist.gov 
[sudo] password for ubuntu: ntpdate[3237]: step time server offset - 12.151112 sec 
  • When you reboot, does your system changes the time, or does it stay as before you changed it? – Saifallah Dec 13 '10 at 13:44
  • No, time stays the same. – t3ch Dec 13 '10 at 16:28
  • What exactly do you click on when the system freezes? Just the time and date in the top panel? – Stefano Palazzo Dec 14 '10 at 0:59
  • @Stefano, I have added the snapshot of the button I am clicking. – t3ch Dec 14 '10 at 2:43
  • Is your Hardware clock set to local time or UTC? – lazyPower Dec 15 '10 at 4:28

Have you tried a console alternative to setting it from the gnome-panel time applet? ntpdate is a favorite of mine. i have it setup in a cron script across several Machines and VM's to ensure my system clock never gets skewed that far off. (once a week is fine by my standards. i find that I only migrate away from Atomic Time a few microseconds a week.)

However, with that said, give a try with

 ntpdate time.nist.gov

and see if it corrects your time issue, without a freeze.

If your system continues to freeze, see if you cant ssh in from another machine and have a look at /var/log/messages. On a Fedora system at one point i was 2 hours ahead of actual time, when i reset the date, it caused a panic because everything on the system was 2 hours ahead. Threw some ridiculous error about future time and locked up. I powered down the machine for a day and gave it another go in a recovery console without an issue.

Edit 1: Another thought occured to me to try and change your TimeZone settings. See if that will reconfigure your clock. See the article located at https://help.ubuntu.com/community/UbuntuTime

This may be a byproduct of messed up TZ settings.

  • Tried your solution, Still 1 hour difference. ubuntu@ubuntu-XPS-M1330:~$ ntpdate time.nist.gov 13 Dec 21:44:37 ntpdate[3098]: bind() fails: Permission denied ubuntu@ubuntu-XPS-M1330:~$ sudo ntpdate time.nist.gov [sudo] password for ubuntu: 13 Dec 21:45:14 ntpdate[3237]: step time server offset -12.151112 sec ubuntu@ubuntu-XPS-M1330:~$ – t3ch Dec 14 '10 at 2:46
  • 1
    @t3ch Remember to update your original question with each thing you try, I've gone ahead and added it for you. – Jorge Castro Dec 15 '10 at 3:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.