Using Nautilus I can connect from Ubuntu 12.04 (64-bit) to my Apple Airport Extreme using user & password without a problem. I can read, browse folders and delete files. However I cannot write files, the file is created, but the contents of the file are not transferred.

The transfer fails with the error message "kFPMiscErr" which I think means that "authentication has already been established" ?.

I have tried the command line tools for access using AFP but these do not work either.

Is there a solution to this problem ?


Try to connect to it using SMB protocol. I tried it and now I can connect from Ubuntu 12.04 64 bit to Apple Time Capsule, read, write and delete files on it. I read this discussion on Apple discussion: https://discussions.apple.com/thread/2691164?start=0&tstart=0

Before using the smb protocol (i.e. with the afp protocol) I got: kFPMiscError If I tried to copy some files on it.

Example smb://user@num1.num2.num3.num4

The problem is: it works just if you are on the same network!:( From a non local network through the protocol afp on Ubuntu 12.04 I found you can copy or move files already written in the Time Capsule folders. Anyway the goal would be copy files not empty on it from anywhere.


in 13.04 afp://name@adress works by default

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.