I have installed a number of operating systems, including Fedora. Most recently I installed Ubuntu, and Ubuntu installed its own version of the GRUB bootloader. However, Fedora does not show up on the list of operating systems to boot from.

How can I get Fedora back in my boot menu?


Mount the other partition, and then run sudo update-grub.

To do that, open nautilus, and then right click the drive like shown below and click "Mount":

enter image description here

After that, run sudo update-grub in a terminal.

Fedora should show up. Now when you reboot, you can select it.

| improve this answer | |
  • 4
    just curious, why would grub not find the unmounted partition? is this a bug related to Fedora/other non Ubuntu Linux flavors? I've dual boot 2 versions of Ubuntu and not had to mount the other partition to get grub to find it...BTW I'm not criticizing your post, seem logical to me, I was just wondering why the workaround was necessary – TrailRider Aug 4 '12 at 16:01
  • @TrailRider I removed ubuntu 12.10 and installed Linux Mint 13 incase there is bug in ubuntu, I got the same result i.e. fedora missing from boot menu. – bernaulli Aug 4 '12 at 16:51
  • @TrailRider I've no clue. Fedora recognizes Ubuntu fine, Ubuntu recognized my Debian install fine, it just doesn't like Fedora. shrug – jrg Aug 4 '12 at 16:56
  • 1
    I think ubuntu can't mount lvm partition by default. sudo apt-get install lvm2 so, you can mount fedora boot partition and update grub. – soroosh Apr 28 '13 at 17:45

The OP asked "How can I get Fedora back in my boot menu?"; at least one answer was provided that resolved the same issue that I had with Ubuntu & Fedora boot menus. Might wanna mark it as "Solved"?

Here's another link to the Fedora forums where the same problem was resolved by an answer that was posted here, and the thread was consequently marked as "Solved":

Grub (Ubuntu) does not detect Fedora 17

| improve this answer | |

This may be a bug in 12.10....

Can you boot in to Ubuntu 12.04, then run boot repair or use the following commands to see if you get access to Fedora from grub?

sudo grub-install /dev/sdX
sudo update-grub

Replacing sdX with the actual drive, which will probably be sda, but use disk utility to double check if you are unsure.

| improve this answer | |
  • It doesn't work – Anwar Aug 4 '12 at 16:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.