First, I used Ubuntu Tweak's clean up feature, so I may have accidentally removed something important through that...

So I just moved my home folder from the main partition to it's own partition so that I don't have to worry about it dieing if I change distros or upgrade distros.

So the path I took was Boot from live usb. Opened GParted, shrink the main partition, create a new partition out of that. Moved the current /home content to /home_backup. Edited fstab to boot the new partition as home.

I rebooted. I assumed the instructions I was working off of would work, but was a tad confused when through the instructions I never saw anything about copying the /home_backup to the /home directories. Anyways, upon login I got lots of errors, and decided I should check out what went wrong.

I rebooted into recovery mode and listed the contents of /home. Nothing, so I copied /home_backup/don to /home (cp -r).

I rebooted and found that I didn't have ownership of the directory, so I opened the terminal and gave myself ownership (chown don:don /home/don) and rebooted again.

This time when I logged in I found that everything was working, but I didn't have sound. So, as far as I can tell all of my apps are still working, and there are no other errors, but I can't play sound.

The sound icon in my panel is just an empty, blank speaker (I'm using the Faenza icons, the speaker icon is lighter than normal). If I attempt to mute/unmute or raise/lower the volume with my hardware keys, nothing happens. If I click on the icon and choose "Sound Preferences" I get an error saying "Waiting for sound system to respond".

I have restarted the computer twice, I've also reinstalled everything containing the word "alsa" through the synaptic manager.

I would assume it's missing a file, but I'm not sure. Right now I've run a dist-update (for different reasons), so I don't know if that'll have any effect on the problem.


It sounds (no pun intended) like some hidden files in home not being transfered to your new home. Check if you have any .pulse files in your home folder. The other option is about permissions easiest way to check is by running this command in terminal.

pulseaudio --start

And check the output if it looks somthing like this

E: core-util.c: Home directory /home/alpha not ours.
W: lock-autospawn.c: Cannot access autospawn lock.
E: main.c: Failed to acquire autospawn lock

then it is probably a permisions issue which wouldn't surprise me. if this is the case then check out this post by drs305 on the Ubuntu forums.

Solving .dmrc and $HOME Permission Errors

  • I got a slightly different error, instead of Home directory /home/alpha not ours I got "Failed to create secure directory: Permissions denied". – dkuntz2 Dec 13 '10 at 17:27
  • Marked as answer because it lead me to the answer – dkuntz2 Dec 13 '10 at 18:01
  • I keep forgeting to make a home partition when Upgrading no patience :) I would have checked the exact directory but I have been forced to use Windows Vista :( for almost two weeks as my partner has pinched my laptop and wont let me install Ubuntu on Her machine how unfair is that!!! – Allan Dec 13 '10 at 18:29
  • It's Pulse Audio (.pulse), and I found the exact problem wasn't permissions (everything was set to 0777), but ownership, so the root was still owner, not me. – dkuntz2 Dec 13 '10 at 23:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.