1

I have 11.10 and Windows 7 in dual boot. Today I tried to update grub and I run the following command in terminal:

sudo fdisk -l    
sudo mount /dev/sda6 /mnt 
sudo grub-install --root-directory=/mnt /dev/sda
sudo grub-install

After installation and reboot, it does not show the grub menu (from which I can choose which OS to boot) and it directly boots Ubuntu.

Please help.

marked as duplicate by karel, guiverc, Thomas, David Foerster, Eric Carvalho Sep 22 '18 at 15:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Try holding Shift while booting to get to GRUB. – hexafraction Aug 3 '12 at 13:53
  • i try but nothing happen. which way i can add or recover windows7 loader in boot loader – bugsbunny Aug 3 '12 at 14:12
  • Did you install Ubuntu via wubi? – hexafraction Aug 3 '12 at 14:24
  • no live cd...and before update grub its workig well... and it was also show the grubloader also but now it cann't show grubloader and so i cannot load windows7.. if u cann't understand my problem than i can explain in other way.. because i m not good enough in explain. so plz reply and thank u.. – bugsbunny Aug 3 '12 at 14:37
  • I can understand your problem. I just don't see a way out right now. – hexafraction Aug 3 '12 at 14:46
0

Boot to your live cd.

Then: in a terminal type.........

sudo mount /dev/sdXY

Example:

sudo mount /dev/sda1

Run the grub-install command as described below. This will reinstall the GRUB 2 files on the mounted partition to the proper location and to the MBR of the designated device.

sudo grub-install --root-directory=/mnt /dev/sdX

Example:

sudo grub-install --root-directory=/mnt /dev/sda

Refresh the GRUB 2 menu with

sudo update-grub.

reboot

If this does not work for you - try the link bellow.

https://launchpad.net/boot-repair

Not the answer you're looking for? Browse other questions tagged or ask your own question.