I have just installed Matlab R2011a on Ubuntu 12.04 using a standalone licence. The installation appears to have worked properly, and I have run the following to get rid of an error that everyone (including myself) seemed to be having:

sudo ln -s /lib/x86_64-linux-gnu/libc-2.13.so /lib64/libc.so.6

This got rid of the error, but I still have a problem launching Matlab. Each time I launch it (by typing "matlab" in terminal), the Mathworks software activation window pops up. I provide the path to the licence file, it appears to activate successfully (no errors), but then Matlab doesn't launch. If I try to run it again, the same thing happens.

Does anyone know what might be going wrong? My last install was 10.04, and I had absolutely no problems running 2011a.

  • FWIW, I am having the same problem on Windows 7 with MATLAB R2015b.
    – Qwertie
    Dec 4, 2015 at 0:24

7 Answers 7


I think the licence should be updated. I fixed the problem by requesting a new licence from Mathworks and activating MATLAB with that licence file. They provided the same installation key for my computer's host id, but the 'licence.lic' file is updated. I think reinstallation is not necessary, activation with an updated licence just solves the problem.


Just change your system date to the previous years and launch the application!

You can do this from the command-line using:

date +%Y%m%d -s "20120418"
  • This worked for me!
    – Richard
    Jan 10, 2019 at 15:25
  • Thanks a lot, its also worked for me. but when i change it another programs like mozilla browser cant load many pages in order to false date, and change back to correct time affect matlab and cant run it.
    – EsmaeelE
    Feb 3, 2019 at 18:03

Is it possible that launching MATLAB in that way runs the activation tool instead of MATLAB?

Try running /usr/local/MATLAB/R2011a/bin/matlab (change the path according to the location on your system) in the terminal to see if that runs MATLAB. If not, perhaps you can still get some error messages from there that might be useful for your question.


After toying around with the activation client I finally have a good answer as to why MATLAB will not activate. Here are the steps to getting everything working!! This is also assuming that you have MATLAB installed and cannot get it to launch.

Quick questions to ask yourself

  1. Did I launch the installer as root?
  2. Where did I install MATLAB?

If you installed as root (which you should have) then your fine. If not uninstall and install as root.

Ok! Lets get to it!

  1. cd to into where you installed MATLAB For me it was the default that was given but you may have wanted to install it in a different location.

    Default install location: /usr/local/MATLAB/R(year)(a or b)

  2. Now you can list everything that is in that directory by typing ls into the terminal window.

  3. Now type cd once more by typing cd bin (this is where the activation client is stored)

  4. Type in the terminal

    sudo ./activate_matlab.sh
  5. Now a window will pop up just like it did when you were installing it. This time you need check the bubble in front of "Activate manually without the Internet."

  6. Now check the bubble in front of "I do not have a license file. Help me with the next steps."

  7. Here you will find your computers basic install info. This was just to check what your computer login name was and to make sure it is root.

  8. Now go back to the beginning of the activation client menu and fill in the bubble that says "Activate automatically using the Internet."

  9. Do everything you did before except this time at the end of the activation when it asks you to type in the name of your computers user, you need to type root, instead of your username or instead of anything you want to put.

  10. Optional: if you haven't already done it, you can install matlab-support so you can launch it after you finish activating MATLAB. You can do this by typing

    sudo apt-get install matlab-support

I hope this helps! GOOOD LUCK!


Old thread I know, but I just had this same problem. The problem for me at least, was that it is recommended installing matlab with root priviledges and as such when it came to activation the default user to be granted a licens became root. In this way I could only start matlab when logged in as root. Problem is easily fixed by running the activation again outside of root.


Way too old thread but viewed 4523 times and active 16 days ago so still relevant I guess. Here is how you solve it. In my case the folder "~/.matlab/R2015a_licenses/" did not exist. though "~/.matlab" did. So I created R2015a_licenses. Now the problem is this folder was accessible only to root. So the activation application could not write the required file. So change the permission of this folder using "sudo chmod 777 R2015a_licenses". Now run matlab normally(no sudo). It should take you to the activation client. otherwise run the activation client manually(no sudo), it is called "activate_matlab.sh" in the bin folder. follow the steps and let it detect the user-name and do not change it. when it exits without error you are done with the licence part. Now there could be another problem that your matlab freezes just after the opening window and doesn't go any further. Take a look at this. "Go to the ".matlab/" directory in the users home directory. Rename the directory named after the version of MATLAB you are using to have _old at the end. If there is a folder with "_licenses" in the name, DO NOT rename that folder" kind of worked. By kind of I mean matlab complained that it cant write preferences in "~/.matlab". So I changed the permission for that folder by "chmod" and then it worked.

If you are still reading your problem is pretty bad. Good luck with it. Mathworks has clearly done a very bad job with matlab ubuntu.


I asked Matlab tech-support how this can be fixed, and they said this issue can occur if you have a previous MATLAB trial license file present on your system.

To fix this delete all files in the following two folders:


(where $MATLAB is the directory where you installed MATLAB. The default is /usr/local/matlab/R2015a/licenses/)


cd ~/.matlab/R2015a_licenses/
rm ./license.lic

Once you have deleted all files within these folders, try launching MATLAB again. Launch it as your regular username, not as sudo or root. You will be prompted to activate once more. Complete the process one last time. Take note on the screen in the activation where it asks you for your Linux username. This should be detected automatically, and you should not change it.

Once the activation has completed, try launching MATLAB again.

Edit: Even if you get an error saying "no such file or directory" on entering the first command, you should enter the rm command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.