16

I know that you can go into the System Settings->Keyboard->Shortcuts and change the bindings for switching between workspaces in the Navigation tab, but this isn't working for me. I can change many other things in Shortcuts, like the shortcut for opening terminal, but for some reason I cannot change the navigation bindings. Is there another way to change this or is there someway to get it to recognize my changes there?

And just so we are clear, I have tried changing it in the Navigation tab to CTRL+(LEFT/RIGHT/UP/DOWN) and F1/F2/F3/F4 and CTRL+ALT+SUPER+(LEFT/RIGHT/UP/DOWN), but none of those work, it just doesn't respond to any of my changes and stays as CTRL+ALT+(LEFT/RIGHT/UP/DOWN)....

Any help would be appreciated, I have been search for 2 days for this and everything says to change it in the System Settings->Keyboard->Shortcuts, but it doesn't work...

1
20

Finally I've found a solution.

It appears, that you need to manually edit settings with the dconf-editor (dconf-tools package).

To edit workspace keyboard binding one should use dconf-tool and edit settings under path org -> gnome -> desktop -> wm -> keybindings.

The syntax for keybindings is the same as in other Gnome editions and the same as displayed in "System Settings->Keyboard->Shortcuts".

1
  • 1
    Pretty useful when the Back and Forward Navigation shortcuts in Intellij didn't works, even after disabling the shortcut using the GUI tool. – Giovanni Toraldo Oct 29 '14 at 12:16
1

You can also set them in the console with

gsettings set org.gnome.desktop.wm.keybindings move-to-workspace-left "['<Control><Shift><Alt>Left']"
gsettings set org.gnome.desktop.wm.keybindings move-to-workspace-right "['<Control><Shift><Alt>Right']"
gsettings set org.gnome.desktop.wm.keybindings move-to-workspace-up "['<Control><Shift><Alt>Up']"
gsettings set org.gnome.desktop.wm.keybindings move-to-workspace-down "['<Control><Shift><Alt>Down']"

changing the given key combinations as you see fit.

Left and Right don't make much sense in vanilla Gnome 3, because the workspace layout is strictly vertical, but I use the Workspace Grid extension, so that's why I listed them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.