I just bought a Canon MG5250 multifunction printer because I thought that it would work well with Ubuntu, and the printing function is installed using these instructions.

But I still need to get the scanner to work and my attempts so far have not helped:

  1. Thep above instructions don't do anything: SimpleScan still says there's no scanner detected.
  2. I found this post in the Ubuntu Forums but it's too terse; it refers to "patching libsane source" but doesn't explain this. As a beginner, I need more precise instructions.
  3. scanimage -L responds with No scanners were identified.
  4. sane-find-scanner responds with found USB scanner (vendor=0x04a9 [Canon], product=0x1749 [MG5200 series]) at libusb:001:002. Your USB scanner was (probably) detected. It may or may not be supported by SANE.

Should I try the approach about "patching libsane source" or can you recommend a better/smarter/ simpler solution?

I like SimpleScan very much for its simplicity so if a recommendation is to switch to some other software, it should be something equally one-click simple.

  • Canon have chosen not to provide much Linux support. For 'one-click simple' you should plug in a USB thumb drive and scan as a standalone unit. For controlling it from Ubuntu, you install Canon's ScanGearMP which is accessible from within Gimp. I also think both your questions are probably duplicates of this one. Commented Aug 3, 2012 at 6:11
  • @TomBrossman: If scanning is only supported into GIMP and not into SimpleScan then that's a major bummer. I want to scan receipts to PDF, not photos. Can GIMP make multi-page PDF's? Commented Aug 3, 2012 at 8:33
  • I agree. To make multi-page PDFs you have to scan each page as an image, then drag each image to it's own page in a LibreOffice Writer document, then export to PDF. All I can recommend is just go back to a HP for your next printer when your ink runs out on the Canon. The price difference between refills and a new printer is often small. Commented Aug 3, 2012 at 17:00
  • @Tom so you're saying that Canon just won't work? That would be sad. I got the printer with lots of refills so it will take a while to use up. I could of course just boot into Windows instead - but I'd like to switch to Linux. Commented Aug 4, 2012 at 7:38

6 Answers 6


I just delved into the packages, they do provide a sane module for canon multi-function scanners. And the second package does contain the right files.

Firs thing though, cd dpkg -i is complete rubbish, that's not a valid command and would never work no matter what. I'm editing it out of the other answer so other people aren't confused by it.

I would get you to list the sane backends, but sane is very poorly designed and can't be bothered to include diagnostic functionality. The only thing to try is redownload the scanner package from canon, extract the files and double click on the common i386 package followed by the mg i386 package and install them via the software center.

Use scanimage from the command line to confirm if it's now working scanimage -L and if not, restart the computer and check again.

  • Thank you Martin, I will try these steps and report back -- but it will be next week because I am traveling until then. Thank you also for editing the bad parts out of the other post. Commented Aug 14, 2012 at 15:34
  • I updated my question with points #3 and #4. Basically the scanner is detected by SANE but apparently not usable. Typing man scanimage as suggested by scanimage totally overwhelmed me. What could be good next steps? Commented Aug 20, 2012 at 19:59
  • Hmm, yes. scanimage -L should list the scanners detected and scanimage > output.pnm should perform a standard scan. If it's scanning from the command line then simplescan should work too. My guess though is that you'll see the error there and can post it here. Commented Aug 29, 2012 at 4:17

Just use the Canon software : type scangearmp in command line.

  • Doing this confirms that the installation of the Canon software was successful -- because I get a big ugly scanner application. It works, but it's nowhere near the convenience and elegance of Ubuntu's SimpleScan. Commented Aug 20, 2012 at 19:53

This question has been annoying me since the beginning.

Finally, with the installation of Ubuntu 13.04 this problem has solved itself because in this version, Ubuntu's built-in SimpleScan recognizes my existing Canon MG5350 scanner, so I can finally have a one-click scanning function.

Solution: upgrade to Ubuntu 13.04.

  • Unfortunately the support in SimpleScan seems to be broken in 16.04 again. While SimpleScan and also scanimage -L finds the scanner, it fails to use it. There's a bug report about this. If you're on 16.04 maybe you can confirm that the scanner does not work out of the box. The original canon drivers still work, but you can't use the nice and simple SimpleScan anymore. Commented Jul 25, 2016 at 7:32
  • If you're affected, upgrading to the latest experimental package of libsane and libsane-common fixed it again for me. See here: askubuntu.com/a/717682/18373 Commented Jul 26, 2016 at 15:10

While the scanner worked with simple-scan worked out of the box for Ubuntu 14.04, it's again broken in 16.04. scanimage -L identifies the scanner successfully, simple-scan also lists the scanner, but scanning fails with a connection error.

If you're affected you can try to use the solution described here and use the experimental libsane and libsane-common packages from Debian experimental. Versions 1.0.26 did the trick for me.

  • 1.0.27 is ok too. :) But I had to use the --auto-deconfigure option to install libsane experimental because it would break dependencies for all other sane packages.
    – w-sky
    Commented Oct 19, 2017 at 4:50

Easier to use ScanGearMP: open the home folder and do a search for "scangearmp'. In the results you will find an executable scangearmp with size 223,9 KB. Right click on this entry and choose Copy to > Desktop. An icon is added on your desktop, just double click on it and the Canon scanner utility starts.

  • 2
    I just tried this and got no search result. That's interesting though, maybe I will find where it installed to and create a custom .desktop launcher. Someday... Commented Sep 28, 2012 at 13:16

You can find it /usr/bin/scangearmp so go to the /usr/bin/ and copy to the desktop (you must use copy -> desktop function).. This is a bad way to do it.. Why Canon is not made it better. I just bought this mg5350 and I don't know if I must take it back to store

Scanner working with my Ubuntu 12.10 x64 in every app, but not with 12.04 x86

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .