9

I am running Banshee 1.8.0 on a more-or-less vanilla Meerkat installation. I was most pleased when I plugged in an old iPod Nano and it Just Worked.

However, when plugging in the iPod, Nautilus/Gnome asks for an application to handle the newly inserted iPod. The dialog presents no applications that can handle the device and allows no manual choice.

inserted audio player dialog

I have reinstalled banshee with apt-get purge and also install --reinstall but neither added an association. As before, when manually opened, banshee happily talks to the iPod, it just won't launch on plug.

I suspect there is a missing association in gconf or something similar but I'm not sure where this information lives.

2
  • odd, there is no option for me to put a +100 bounty on this question, I hope that flagging it for a moderator may help. – msw Dec 14 '10 at 13:25
  • You can only add a Bounty after a question has been two days old. So if you sit tight by this time tomorrow you should be able to "slice off" some of your hard earned rep and put it up for a Bounty! – Marco Ceppi Dec 14 '10 at 15:23
1

First try to set your preferred application for the media player in System->Preferences->Preferred applications:

alt text

If you don't have banshee in your list, select custom and add command /usr/bin/banshee. And if that doesn't work you can try also with File manager preferences:

alt text

Where I have set "Ask what to do", try to set as banshee

old: THIS might help as this happend before.

5
  • No, that tells what to do if banshee can't see the player which is not what is wrong. Banshee can talk to the iPod just fine. The problem happens when I plug in the USB device and there are no programs available to serve the iPod. – msw Dec 12 '10 at 22:23
  • Oh well then just manually add banshee. Its location is /usr/bin/banshee – danizmax Dec 12 '10 at 23:18
  • As the dialog I added to the question hopefully makes clear, I am never presented with the option to tell it to use banshee. – msw Dec 13 '10 at 0:58
  • and both of the dialog boxes you showed display a greyed out "No applications found" message for me, but +1 for trying, thanks. – msw Dec 14 '10 at 13:20
  • Wow the problem must be a lot bigger then. I'm guessing it could be udev problem – danizmax Dec 14 '10 at 21:45
1

It sounds like the MIME type database may be incomplete. Normally, the following should list about a dozen lines corresponding to types of media that can be assigned auto-run preferences:

grep x-content /usr/share/applications/mimeinfo.cache

If they don't show up, first verify that the following returns a line containing audio-player:

grep x-content /usr/share/applications/banshee*.desktop

Then try regenerating the database by running:

sudo update-desktop-database --verbose

If that doesn't help, setting the following in ~/.local/share/applications/mimeapps.list should function as a lazy workaround:

[Added Associations]
x-content/audio-player=banshee-1-media-player.desktop;
0

This may be a stab in the dark, but:

  1. Create a file ~/.local/share/mime/x-content/audio-player.xml (creating folders along the way if necessary)
  2. Put the following in it:

    <?xml version="1.0" encoding="utf-8"?>
    <mime-type xmlns="http://www.freedesktop.org/standards/shared-mime-info" type="x-content/audio-player">
      <!--Created automatically by update-mime-database. DO NOT EDIT!-->
      <comment>portable audio player</comment>
    </mime-type>
    
  3. Now try to set the default audio player for inserting an audio device.


Also, you could try:

update-mime-database ~/.local/share/mime

but I've never tried that... I have no idea if it will do what you want. From the man page:

update-mime-database is an program which is responsible for updating the shared mime-info cache according to the system described in the Shared MIME-Info Database specification from the X Desktop Group.

2
  • Alas, no change, but thanks for the attempt. The layers of indirection in the desktop functions is staggering. This trivial problem has now become my vehicle for trying to make sense of the tangled mess. – msw Dec 15 '10 at 7:32
  • @msw: Yeah, me too. I went to dig you up an easy answer... and ended up more confused than before. – Nathan Osman Dec 15 '10 at 19:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.