15

There is any good font editor for ubuntu? Like high-logic Font editor for win. I tried Doubletype, but not worked very well, and really outdated.

19

You can try fontforge. It is available in the standard repository. Though the GUI is somewhat messy, but it's powerful and I've used it to change names of fonts.

Click the button to install:

Install via the software center

Or with this command:

sudo apt-get install fontforge

There is another front-end to fontforge. it is mensis. Install it with

sudo apt-get install mensis

Or using this link: Install mensis via software center

If apt-get says, no such packages, use this command to refresh package database

sudo apt-get update

See this excellent FAQ in the fontforge site at sourceforge.net . And If you like reading good writings and have time to read the history of fontforge, I recommend you to read this excellent article too!

3
  • 2
    Fontforge can do the job, but not user friendly, with better ui it can be a score! Thx for the answer, it was helpfull. – c001os Aug 2 '12 at 20:45
  • 1
    @c001os See the Faq link in my answer. I think, your query about better ui has an answer there already. Thanks. :) – Anwar Aug 3 '12 at 8:39
  • Thy, but i can hardly say mensis is super user friendly :). But thx. – c001os Aug 31 '12 at 20:18
8

See also BirdFont. It is available in the Universe repository since Ubuntu 14.10 (Utopic Unicorn).

Install with this command :

sudo apt-get install birdfont

Newer versions can be installed from an upstream PPA :

sudo add-apt-repository ppa:birdfont-team/birdfont
sudo apt-get update
sudo apt-get install birdfont
5
  • just tried installing birdfont on Ubuntu 14.04, got error on launching: birdfont: error while loading shared libraries: libxmlbird.so.1.0: cannot open shared object file: No such file or directory – xealits Jan 28 '18 at 14:49
  • @xealits Did you try to install libxmlbird ? – Skippy le Grand Gourou Jan 29 '18 at 13:39
  • yes, I get E: Unable to locate package libxmlbird, the ppa is added and I ran sudo apt-get update. Maybe it's not available for trusty? – xealits Jan 29 '18 at 15:10
  • 1
    I checked and the package is actually named libxmlbird1. However it seems available only since 16.04, so you'll have to find a way to install libxmlbird manually. – Skippy le Grand Gourou Jan 29 '18 at 17:40
  • Maybe try to install manually this deb (if amd64) or this deb (if i386). I'm not sure how to install them directly from the PPA, but once downloaded you can install them with sudo dpkg -i /path/to/package.deb. I'm afraid I cannot help you further. – Skippy le Grand Gourou Jan 29 '18 at 17:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.