ALT+Tab functionality has suddenly started misbehaving. it's showing only desktop and the current active app instead of all the applications opened.

For eg currently, opened applications are firefox and terminal but when i press ALT+Tab I can see either "desktop + firefox" or "desktop + terminal" depending upon whether the current active application is browser or terminal.

I have not installed any update.

Please help.

  • does it mean that it is Freshly installed Ubuntu 12.04 ?
    – atenz
    Commented Aug 2, 2012 at 6:52
  • nope this isn't a fresh install; i installed ubuntu 12.04 around 2 weeks ago.
    – Ankit
    Commented Aug 2, 2012 at 6:55
  • Then not installed any update means , Not updated your Ubuntu yet ? . I am just clarifying :)
    – atenz
    Commented Aug 2, 2012 at 6:57
  • i updated it in the 1st week, not after that
    – Ankit
    Commented Aug 2, 2012 at 7:05
  • 1
    I believe the expected behavior for alt+tab right now is to switch between application in current desktop only. It helps to isolate your different tasks by putting them in different desktops. Of course this can be confusing at first if you expect to scroll through all your open apps -- but trust me its so much better when you get used to it. Try it for a few days and get a feel of how you can leverage the power of multiple desktops. If four desktop is too many at first, try to reducing it down to two until you get a good feel of multiple desktop interaction.
    – Aras
    Commented Aug 2, 2012 at 7:28

6 Answers 6


Are the apps on different desktops? The Alt+Tab switcher cycles through the apps on the currently active workspace only.


I had this problem with the 12.10 beta 2, although I don't know precisely why it behaved that way, here is how to fix it.

Go to your System Settings > Window Behavior > Task Switcher

Now, on the right side, under the heading "Filter Windows By", the Minimization setting should either be set to "Visible windows" or deselected entirely. That fixed it for me.

If it is set to "Hidden Windows" it tries to show the desktop, it minimizes all other windows, and just seems to behave weirdly.


I'm on 12.10. I tried all that and messed around with compiz but the settings were missing.

I logged out and logged in a "gnome classic session (no effects)" and it seems to work for now


I also had this problem with 12.04 but neither of the above solutions worked for me.

My solution was to open the Ubuntu menu, and choose System Tools -> System Settings, then under Hardware, open Keyboard, click the shortcuts tab, choose Navigation from the left, and scroll down on the right to find "Switch Applications". When you click that it shows "New Accelerator..." - at this point just press ALT-TAB and its set

Its worked perfectly for me ever since. hope that helps someone...



I had the same issue, none of the above soltution helped.

Actually, in my case, I went back from unity to gnome using the fallback application and these hotkeys were not working. I found the solution there: http://www.qc4blog.com/?p=1407#comment-1614

It has to do with compiz and the application switcher has to be enable..


The link to the blog given by MarK helped me find the solution but the blog missed a step:

The blog has you install the compizconfig-settings-manager but not compiz-plugins. This is definitely a workaround but it worked for me in the "gnome classic session".

from: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/971051


  1. Install packages: sudo apt-get install compiz-plugins compizconfig-settings-manager
  2. Run "ccsm"
  3. Scroll down to Window Management and enable (tick) "Application Switcher".

I personally found that the "Application Switcher" option did not work for me and I had to use the "Static Application Switcher"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .