I used to be able to use Super+Mouse1 both to move a window and to raise the window on click. When I upgraded to 12.04 gnome-panel, it lost this functionality and I was forced to map F1 to raise a window. Now I am auditing Unity. I have disabled click-to-raise and auto-raise behavior as I would rather have control over which windows are raised when.

I am not aware of a way to map the mouse thusly, but I would be happy to hear that it is possible.


I have more or less solved the problem. It's not ideal but it works. In CompizConfig Settings, General Options -> Key Bindings, there are two settings for "Raise Window", mouse and keyboard controls. I set the mouse control to Super+Button1, which does not conflict with Alt+Button1 in the "Move Window" options. I also set "Lower Window" to Super+Button2, for orthogonal operating with clicking the title bar.

Although this does not combine raise+lower like I am used to, it allows me to access raise/lower while using the mouse, so it's good enough for my purposes.


The conventional way to move a window with Linux (Gnome?) is to use Alt+Left-click. This has been fairly standard for as long as I remember. Alt+Middle-click resizes.

I just tried it with 12.04 Unity, and it didn't work with a standard install (in a VM for testing), but alt+middle-click still works to resize.

There is a "move window mode" entered by the shortcut combo Alt+F7, which is not nearly as convenient, but will work in a pinch.

  • I have Super+Mouse1 mapped to "Move window" just fine. What I mean is that I used to be able to raise the window to the top of the z-order just by clicking that same combination. It no longer works that way. – Robert Earl Aug 1 '12 at 23:33
  • In that case, you question is not clear to me. Usually, a normal click on a window will raise it, so I thought your problem was raising + moving, not just raising. You might try editing your question to be more clear, and perhaps removing unneeded comments like why you stopped using gnome-panel in favor of Unity, since that has nothing to do with the problem. – Marty Fried Aug 1 '12 at 23:41
  • "I just tried it with 12.04 Unity, and it didn't work with a standard install" ... Working fine for me in a non vm. – trent Aug 1 '12 at 23:48
  • I have explicitly disabled click-to-raise because I do not want just any click to raise windows, rather, I want control over window layering. I have also disabled auto-delayed-raise of windows. It is therefore vital that I have an easily accessible method of raising windows. F1 was an acceptable hack, but I would much rather just have the default behavior back. – Robert Earl Aug 1 '12 at 23:51
  • I am sorry if I offended Ubuntu apologists by insulting gnome-panel, but I thought Unity was so awful that I declined to use it for a good long time, and now gnome-panel has utterly failed me by refusing to allow windows to hang partly off the desktop. I edited my question to omit the offending remark, but upon rereading it, my core question seems abundantly clear, so I am unsure of how to help you understand what I want to do. – Robert Earl Aug 1 '12 at 23:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.