Having tested all the solutions that I could find on the net, I try my luck here:

I use Precise Pangolin, version 32bit kernel with pae


  • Suspend goes well, but on resume, my screens remain on standby, the pm-suspend logs do not indicate anything special.
  • Hibernation: Everything seems to run fine, the message indicating the creation of the image is displayed briefly, monitors go into standby, but the machine does not poweroff, on the contrary, the fans speed up, manual forced poweroff is the only solution, and at reboot, there is no resume.

Hardware configuration:

  • graphics card: nvidia 8600 GTS (using the Nouveau driver)
  • Motherboard: ASUS M5A88-M-EVO
  • 8G of RAM, 10G swap.

Things i tried:

  • Installing the nvidia proprietary driver: partially solves the problem (suspend is functional, correct extinction but not resume (monitors stay off) for hibernation), but unstable system, hibernation is not useful if one need to reboot that often, impossible to work.
  • Uninstalling kvm / vmware / virtuabox that were installed. no change.
  • Compile linux 3.5 with Nouveau driver and libdrm (all this from freedesktop.org git repositories), it works very well, but no change for suspend/hibernate.
  • Adding nomodeset kernel options at boot, I lose 3d acceleration (unity 2d), and no improvement.
  • Installing the script to disable usb ports to hibernation, no change.
  • Updated bios, no change.
  • Forcing the bios in S3 mode for hibernation, no change.
  • Launch pm-suspend manually with all the possible quirks options, no change
  • Changing the method of shutdown of pm-hibernate from "plateform" to "shutdown" (no change)
  • Reformat the swap partition (swapoff/mkswap/swapon/fstab edition/edition /etc/initramfs-tools/conf.d/resume), no progress, get a new warning message about the UUID used, I may have forgotten something here.
  • Installing hibernate/uswsup/tuxonice, and uninstall them, no change in any case...
  • Added "resume=/dev/sda4" (my swap partition) to the line of the boot, no change.
  • Added "noacpi" to boot kernel line, no change.
  • Added "acpi=force" to boot kernel line, no change.

I think that's all, but I spent several evenings on the above, I may have forgotten some of it…

I would really, really like to make it work, suspend OR hibernate, if anyone has a solution or even more trails to explore, my gratitude is great ... (yes, I can pay for beers if you are in paris or you come by there ^^).

lsmod : http://paste.ubuntu.com/1124079/

lshw : http://paste.ubuntu.com/1124082/

  • Ok, this is just a workaround, and a confirmation issue is GPU related, i removed the Nvidia card to use onboard ati gpu, and at least suspend-to-ram works.
    – tshirtman
    Aug 5, 2012 at 17:56
  • Problems with suspend/resume are very common and currently there is no easy solution for that. Unfortunately requesting bug reports doesn't resolve issue. But try request this bug report directly to freeesktop.org. I've done already with similar problems about nvidia and nouveau.Link: bugs.freedesktop.org/show_bug.cgi?id=57081
    – karolszk
    Nov 14, 2012 at 19:47
  • @tshirtman, was this issue ever resolved for you? I am having your exact same problem on a desktop with with a GTX970.
    – csvan
    Feb 24, 2016 at 7:17
  • @csvan not really, i've been using the onboard amd gpu ever since. I do have working suspend (to ram) at work with nvidia, i don't know what's the difference.
    – tshirtman
    Mar 1, 2016 at 8:12
  • 1
    @tshirtman I have wasted hours upon hours trying to resolve it. If it is any help, I am becoming increasingly convinced that at least suspend-to-ram is a hardware issue, not a driver/os/software one. My only backing for that is that the exact same issue occurs in Windows 10, and that certain hardware buttons on my rig become unresponsive when it happens.
    – csvan
    Mar 1, 2016 at 8:14

2 Answers 2


Just to confirm thirtman: I"m running 12.04 32bit on an Asus laptop with Geforce 9650M GT. Ran find under maverick with proprietary driver. Upgraded to 12.04, where nvidia was replaced with nouveau. Suspend worked initially, hibernation did not. However, suspend with an external monitor connected did lead to the black screen upon resume. So I thought nvidia current was a good idea. To no avail. Get the same black screen, but now even when I resume from suspend without external monitors. nvidiacurrent (302.17) leads to unstable behavior, first small parts of the frame flash, after a few minutes the screen goes black, then immediately white, and slowly a black pixel structure emerges from the top and bottom of the screen. Looks quite nice, except system doesn't respond to any keys. I reinstalled nvidiacurrent several times, the system ran smoothly on the first one or two boots after reinstallation for a whole day, but then goes unstable every time. Very annoying. For the record: after deactivating nvidiacurrent, I had to also remove /etc/modprobe.d/nvidia-current-hybrid.conf by hand to restore the nouveau driver


Any reason why you're not using 64-bit Ubuntu?

I remember at least one instance where the Nouveau driver has problems with memory allocation when suspending (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/754711), this can be alleviated by using a 64-bit kernel (or by using the proprietary drivers which are not working that well in your case).

  • I think i had issues some time ago that i thought could be attributed to 64bit so i played it safe at reinstallation, not sure it was that, if 64bit can fix this, i'll give it another go really soon! thanks for the suggestion. (but for memory allocation, pae should give me as much possibilities than 64bits, right?)
    – tshirtman
    Aug 1, 2012 at 21:22
  • Ok, so i installed a 64bit version on a separate partition, to no avail, suspend/hibernation are still brocken in the same way, thanks for the suggestion anyway.
    – tshirtman
    Aug 4, 2012 at 8:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .