6

Since the changeover from ffmpeg to avconv, the -psp option does not seem to render video correctly for Sony Walkman - "file format not supported", it was perfect before.

ffmpeg -i video.avi -f psp -s 320x240 -vb 500k -ac 2 -ab 128k
video.mp4

Even the "long hand" version does not produce working results.

ffmpeg -i video.avi -acodec libfaac -ab 128k -s 320x240 -vcodec
libx264 -b 500k -flags +loop -cmp +chroma -partitions
+parti4x4+partp8x8+partb8x8 -flags2 +mixed_refs -me_method umh -subq 6 -trellis 1 -refs 5 -coder 0 -me_range 16 -g 250 -keyint_min 25 -sc_threshold 40 -i_qfactor 0.71 -bt 500k -maxrate 768k -bufsize 2M -qcomp 0.6 -qmin 10 -qmax 51 -qdiff 4 -level 13 -threads 0 -f mp4 video.mp4

Does anyone have any ideas?

1
  • Here's the mencoder solution: 'mencoder video.avi -of lavf -lavfopts format=mp4 -af lavcresample=48000 -srate 48000 -vf-add harddup -vf-add scale=320:240 -oac lavc -ovc lavc -lavcopts aspect=24/10:aglobal=1:vglobal=1:vcodec=mpeg4:acodec=libfaac:abitrate=128:vbitrate=500 -o video.mp4' - it's faster too on my hardware.
    – Drac Noc
    Aug 2 '12 at 18:29
4

From Encoding H.264/AAC in MP4 for the PSP:

ffmpeg:

-profile:v main -level 3 -x264opts ref=3:b-pyramid=none:weightp=1

Note that you are no longer using ffmpeg from FFmpeg, but avconv from a fork called libav. The example command is specifically for ffmpeg (the real one).

2

It would seem that ffmpeg are a bit random when it comes to options that are enabled in the package.

ffmpeg seems to change command line options with EVERY release....I wish they wouldn't do that. Because of that, I am not overly fond of the ffmpeg dev team or project. I find ffmpeg so annoying for conversions that for PSP use I just use Handbrake. Yes, Handbrake is still ffmpeg, but THEY figure out the options.

Quoted from User CronoCloud on the Fedora Forums

Also John Stebbins the Handbrake PPA maintainer had this to say about PSP in Handbrake

The PSP preset was dropped in the latest version of HandBrake because there were multiple reports of incompatibility between the preset and different flavours of the PSP. It seems that differences in firmware versions etc. make it very difficult to create an officially sanctioned preset for it. Here's a thread on handbrake's forums discussing settings that worked for some users.

This is the link he was referring to

https://forum.handbrake.fr/viewtopic.php?f=7&t=13354&p=72244&hilit=psp#p65660

The topic lists what kind of options work in particular situations you will have to find which one works for you. When you do either add it as a note to your question or as an answer to your question

Hope this helps.

4
  • Many thanks for the link, I managed to "fix" the problem using Mencoder. As you pointed out, ffmpeg options seem to change on a whim - too ugly for my liking. Thanks again.
    – Drac Noc
    Aug 2 '12 at 18:28
  • I would add your solution as an answer it will make it easier to search for any one with the same problem. It might be a good idea if you include some info about what version of Walkman you are using
    – Allan
    Aug 2 '12 at 19:29
  • 1
    All done. I just hope this helps some other poor soul in the same predicament. Now all I have to do is alter all my Thunar custom actions... oh joy.
    – Drac Noc
    Aug 2 '12 at 19:49
  • you might need to call on the power of Thor marvel.wikia.com/Mjolnir
    – Allan
    Aug 2 '12 at 21:12
1

Here's the mencoder solution:

mencoder video.avi -of lavf -lavfopts format=mp4 -af lavcresample=48000 -srate 48000 -vf-add harddup -vf-add scale=320:240 -oac lavc -ovc lavc -lavcopts aspect=24/10:aglobal=1:vglobal=1:vcodec=mpeg4:acodec=libfaac:abitrate=128:vbitra‌​te=500 -o video.mp4

This works great on Sony Walkman NWZ-E454.

1

This helped me encode a bunch of files in one batch for the PSP using the latest (2016) ffmpeg:

for file in *.avi; do
       ffmpeg -i "$file" -b:v 120k -strict -2 -s 400x240 -vcodec mpeg4 -ab 64k -ar 24000 -acodec aac "$file.psp.mp4"
done

May come in handy for someone still using this device

1
  • that's a nice retro workaround. PSP is pretty much dead but well done for keeping it going!
    – Drac Noc
    Mar 20 '20 at 17:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.