13

Sometimes while running apps using OpenGL, the following message comes in the command line where I run the app. I have a Sandy Bridge integrated graphics card (the same as in the bug reports)

intel_do_flush_locked failed: Input/output error

Running any subsequent OpenGL apps fail with the same error. Also this is displayed in the system log

[ 7730.683403] [drm:i915_wait_request] *ERROR* i915_wait_request returns -11 (awaiting 1322416 at 1322415, next 1322417)

I have seen many bugs about this but none of them seem to have a solution. Is there any workaround for this (apart from disabling OpenGL)?

8

Try LIBGL_ALWAYS_SOFTWARE=1 ./yourprogram

  • 3
    This is a work-around at best. – David Foerster Sep 12 '15 at 10:15
  • What is the reason of the error and what does this solution exactly do? – ar2015 May 6 '18 at 11:16
1

The following seems to fixed the issue for me:

export hiz=false
export INTEL_HIZ=0
export INTEL_SEPARATE_STENCIL=0

If it doesn't help try

sudo intel_reg_write 0x2120 0x1206800

Source.

  • I've changed my computer; so I can't test it but I'm upvoting. – Ramchandra Apte Mar 4 '14 at 13:56
  • 1
    @RamchandraApte I think You shouldn't than. – Adobe Mar 4 '14 at 14:02
  • 1
    Doesn't help. Anything else to try? – temoto Jan 25 '15 at 21:24
  • 1
    According to the source of this fix, this helps only with kernels before 3.3, after that the kernel fixes the problem. Did not help me, but I only get the intel_do_flush_locked failed message, not the syslog entry. – Trendfischer Apr 17 '15 at 18:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.