Where I live, there is power outage every few hours. This means my DSL WIFI routergets reset after 2-3 hours max. The network is secured and requires password to connect. So when the router resets and comes backup after a few minutes, my laptop (Ubuntu 10.04) doesnt auto reconnect to it. Instead I am presented with a password entry dialog box to connect to the network. How can this re-connection be made automatic? Is there some retry counts or timeout that I can set somewhere so that the network manager will try for at least 10 minutes to connect to this network before popping this dialog box.


  • can any one help me with this? – binW Aug 8 '12 at 10:12
  • My router is set up with a password, but my wifi saves the password and automatically reconnects every time my router dumps me momentarily or I re-enter connection range after using the machine elsewhere. This works better on my laptop than on my desktop machine (the latter using a USB wifi dongle), but it does work. There's a setting for the wifi to "always use" a connection, which will also cause the computer to store the router password. I'm not at home now, so can't give exact details how to set this, but it's similar in every version of Linux I've tried. – Zeiss Ikon Aug 14 '15 at 11:18

Maybe not the cleanest way of doing this, but you could make a little script and let is execute every 5 min using cron. If pinging the router is not successful then the network manager is restarted.

ping -c 3 -W 10 >/dev/null

if [ $? -ne 0 ]; then
  service network-manager restart
  sleep 5

In my humble opinion, the reconnection is automatic but probably passwords are not stored properly. Network-manager prompt for the password, that means it is trying to connect, otherwise it will just stay silent.

You can open the 'Edit Connections' window of network-manager and check whether passwords are stored. (Image copied from Where does network-manager store WPA keys when "Available to All Users" is ticked?)

network-manager wifi configuration

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.