Despite my best efforts I cannot get google chrome to work on Ubuntu. It's probably due to the fact that I'm not good at terminal commands, but help would be greatly appreciated.

I've downloaded the correct version of Google Chrome for my computer, and I've tried going to Home -- Downloads and double clicking on the downloaded file. It comes up in the software center as an internal error and the file cannot be opened.

I've also tried to write or create the correct paths using the steps mentioned in this help thread I was following these steps --->

sudo dpkg --install /Path/to/chrome.deb

Ignore the errors, then:

sudo apt-get install -f

Then again:

sudo dpkg --install /Path/to/chrome.deb

When I place that into the terminal I also get errors It says

0 upgraded, 0 newly installed, 0 to remove and 447 not upgraded


You said in this comment that you ran sudo dpkg -install /Path/to/chrome.deb and got an error dpkg: error: unknown option -n.

As with most (though not all) commands, a single dash before a sequence of letters designates all the short (i.e., one letter long) options corresponding to each letter, whereas two dashes before a sequence of letters designates that the whole sequence is to be construed as a single, long (i.e., word-like) option.

So you should be running one of these commands instead:

  • dpkg -i /Path/to/chrome.deb
  • dpkg --install /Path/to/chrome.deb

Use either one, they're equivalent. (See man dpkg if you want details.)

Running dpkg -install /Path/to/chrome.deb is wrong because it's equivalent to dpkg -i -n -s -t -a -l -l /Path/to/chrome.deb. (That's why you get an error about dpkg doesn't know what to do with a -n option.)

| improve this answer | |
  • Okay, I fixed that error but the terminal still says that errors were encountered In the last step for some reason. After I ran --install /Path/to/chrome.deb it says that it successfully read and built the dependency tree and package lists then it goes on to say 0 upgraded, 0 newly installed, 0 to remove and 447 not upgraded. =[ then I ran the very last step sudo dpkg /Path/to/chrome.deb and it says "Errors were encountered while processing: /Path/to/chrome.deb – Jenne Jul 30 '12 at 22:20
  • @Jenne The information necessary to solve this is probably too long to provide in comments; also, comments don't keep the formatting necessary to understand the output. Please copy all the text from the Terminal, paste it into your question (by editing your question), and use the <$> tool to format it properly. If you've already closed the Terminal window where you did this, you can do it again to get the text to copy. – Eliah Kagan Jul 30 '12 at 23:47

Maybe you could try installing chromium?

Its almost the same. You can find it in the software center.

| improve this answer | |
  • Understood. Sorry I'm new to this. – Benoit Ranque Jul 31 '12 at 11:36
  • That's okay. I removed my downvote. – user25656 Jul 31 '12 at 12:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.