I haven't used my Ubuntu install in about 2 months. I went on last night and first thing I did was update, but I got this message saying it failed to download the repository and to check my connections, even though my internet is fine. Here is the error log:

W:Failed to fetch https://private-ppa.launchpad.net/commercial-ppa-uploaders/multiwinia/ubuntu/dists/precise/main/binary-amd64/Packages  The requested URL returned error: 401
W:Failed to fetch https://private-ppa.launchpad.net/commercial-ppa-uploaders/multiwinia/ubuntu/dists/precise/main/binary-i386/Packages  The requested URL returned error: 401
E:Some index files failed to download. They have been ignored, or old ones used instead.

I noticed that it has the name of Multiwinia in the file path, which is a game I downloaded from the software store roughly 3 months ago. I removed it to see if that would fix the issue, but to no avail.

Any help on the issue would be much appreciated.

5 Answers 5


Apparently the ppa got added, when you installed the game and now the ppa is broken or suspended. At least that's my best guess. It should be save do remove those repositories from your list. To do so got to:

Remove sources

Software Center -> Edit menu -> Software Sources -> Click the tab Other Sources -> Unselect the ppas in question.

If that doesn't work try to change the download server to the best one:

Select best server

First three steps from above -> Download from -> Other -> Select Best Server

  • I just tried both methods, but neither worked. I do appreciate the help though. Having the visuals is the best thing you could have done!
    – Lokgolo
    Aug 1, 2012 at 6:25
  • That is strange. Are you sure you did deselect only the Software Sources that had "multiwinia" in their name?
    – con-f-use
    Aug 1, 2012 at 7:40

Software in Ubuntu is installed from package repositories containing a number of packages. This is different from the 'click next' installers in Windows. So, you have removed Multiwinia, but the repositories remain there. But having the repositories there is usually not an issue, the error occurs due to unstable Internet connection or repository issues.

To remove the repository, open Ubuntu Software Center > Edit menu > Software Sources > click the 'Other Software' tab > Uncheck the unwanted repositories with 'multiwinia' in it.


Open a Terminal > type:

sudo gedit /etc/apt/sources.list

Remove these lines: [careful with this file!]



Hopefully this solves your issue.

Edit: There are more repository list files in /etc/apt/sources.list.d folder. For example, Google Chrome repos are in /etc/apt/sources.list.d/google-chrome.list

So, you may look in /etc/apt/sources.list.d for files like multiwinia.list and remove the file. Do take a backup before you delete or edit anything unless you are absolutely sure of what you are doing.

  • 1
    Manual editing the sources.list is actually not a good idea.
    – con-f-use
    Jul 30, 2012 at 16:47
  • It's just in case the regular process fails. Standard disclaimers apply.
    – melvincv
    Jul 30, 2012 at 16:49
  • You did a good job, I'll give it to you :)
    – melvincv
    Jul 30, 2012 at 16:53
  • Thanks! And didn't see the first part of you post where you suggest the Software Center. Sorry for the initial downvode. Now corrected.
    – con-f-use
    Jul 30, 2012 at 16:55
  • 1
    That's ok :) Maybe I should give easy and safe answers first. I can always edit my answers later.
    – melvincv
    Jul 30, 2012 at 16:57

Go to Update Manager --> click on Settings ---> Software Sources wizard opens ... then go to other sources --> uncheck the PPA's which are giving trouble.

Once you done with this close the wizard and click on check updates in the Update Manager.


Select tab "Other Software"

From the "Other Software" tab, disable all PPA repositories, leaving only the official Ubuntu repositories active. Enabling too many PPA repositories (which are non-official) can cause your package manager to become unstable.


I have been having the same issue. Unfortunately the USC seems to be having issues with installing previously purchased software all together. My solution has been the following:

  • Log into Launchpad
  • Go To your account by clicking on your name in the upper right of your browser.
  • Click on "View your private PPA subscriptions"
  • Choose View on the previously purchase software listing on this page.
  • Under "Custom sources.list entries" there are 2 lines that show your private ppa information. Copy the first line. (deb https://username:password@private-ppa.launchpad.net/commercial-ppa-uploaders/SOFTWARE/ubuntu YOUR_UBUNTU_VERSION_HERE main #yada yada yada)
  • Open Update Manager and click Settings.
  • When the Software Sources window comes up go to Other Software
  • Remove the Entry that states "Added by..." (I can't quite remember the rest but it has something to do with store in auth.conf in the title)
  • Enter your Admin password when prompted.
  • Paste the line you copied from Launchpad and edit YOUR_UBUNTU_VERSION_HERE (I'm under 12.04 so I put precise there).
  • Click Add Source then Add the next line (deb-src line) and edit the YOUR_UBUNTU_VERSION_HERE to your version and hit Add Source.
  • Click Close on the Software Sources and Refresh.
  • You can find the name of the package through the Software Center, but DO NOT INSTALL IT. The name is shown under More Info (For example MC-Launcher is mc-launcher) it's after Version near the Support Website listing. do not copy the version number just the part before it.
  • Open Terminal (CTRL+T) and type

    sudo apt-get install

    Then paste your package name.

This has been the Only method I have been able to install previously purchased items. And the commericial-ppa-uploaders page results in a timeout. So you can't issue a bug with the ppa owners.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.