I run a rails development environment, which runs a server I can access at localhost:3000. I was doing this again today, and went to restart the webserver and it started timing out.

After some time I ran nmap localhost, and realised that 'ppp' is running on port 3000:

3000/tcp open  ppp

I've never used PPP, and it's stopping me getting my work done. I tried service pppd-dns stop, which appears to have no effect. I even tried sudo apt-get remove ppp, but the port is still open, and I still can't start my rails server.


Well, @whiskers75 answer seemed to work at first, but I've now witnessed the behaviour again and ppp was still not installed - it must have been the reboot that did the trick before.

I used netstat -tulpn to check which processes where listening to which ports, and it turns out that nmap was giving misleading information - it wasn't ppp, but ruby. A rogue ruby process had been left over by a dead rails instance and was still listening to port 3000.

killall ruby did the trick, the port was freed and I could restart my rails server.

| improve this answer | |

Try sudo apt-get purge ppp then reboot.

| improve this answer | |
  • Seems to have worked, thanks very much. (And a quick response too!) – Jason O'Neil Jul 30 '12 at 6:54
  • 1
    Glad to hear it. (I know how annoying it is when it takes hours for a response!) – whiskers75 Jul 30 '12 at 6:55
  • After a while I encountered the problem again. I think the 'then reboot' part of your instructions happened to fix the problem temporarily... but it cropped up again later. I've documented the proper solution below. Thanks for your help though! – Jason O'Neil Nov 8 '12 at 2:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.