I'm very new to Ubuntu. I need a way to install Jad in my system.

Can anyone help me this out?


The JAD Java Decompiler is a handy tool for Java developers, both for academic use and for recovering your own code on those (hopefully) rare occasions when you lose the source but have the .class files.1


To install it, you can download it Here. I recommend that you get the static binary.

It's a 32-bit binary, so you may also want to add the install ia32-libs if you get any problems...

sudo apt-get update

sudo apt-get install ia32-libs

Also move/copy it to something in the path, like /usr/local/bin, so you can run jad

(Thanks to izx for his kindness)

  • I'm getting error like this : E: Unable to locate package libstdc++2.10-glibc2.2 E: Couldn't find any package by regex 'libstdc++2.10-glibc2.2' – batman Jul 30 '12 at 8:57
  • Thanks, I tried installing using dpkg. But I get : dpkg: dependency problems prevent configuration of libstdc++2.10-glibc2.2:i386: libstdc++2.10-glibc2.2:i386 depends on libc6 (>= 2.2.4-4). dpkg: error processing libstdc++2.10-glibc2.2:i386 (--install): dependency problems - leaving unconfigured Errors were encountered while processing: libstdc++2.10-glibc2.2:i386 – batman Jul 30 '12 at 9:27
  • I just installed, using GDebi, and it installed fine. To get GDebi click here – Mitch Jul 30 '12 at 9:49
  • Thanks. I have installed using Gdebi. But when I tried to open jad using command line. I get command not found error. – batman Jul 30 '12 at 10:22
  • you probably need to add it to your path then.. that'll fix your command not found error.. – marc-andre benoit Jan 8 '13 at 0:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.