3

I'm on ubuntu 12.04.

Recently I bought a cheap apple style bluetooth keyboard. It pairs OK. I paired it with the current 102 key still attached.

Anyway I noticed that the character mapping is incorrect. Most keys do not type anything - some keys on the right (k, l, ;') etc give numbers, but that's about it.

So I rebooted, with 102 kbd unattached, and the bluetooth keyboard on, ready to connect.

After boot at the login screen, the bluetooth keyboard had paired. I typed my password, and it logged in fine!! However after the user login was complete it reverted to the broken behaviour. A glance at the layout chart shows ubuntu thinks I still have the 102 layout, even though it remained disconnected.

Any ideas?

Thanks, Dave

3

Keyboard layouts are not automatically changed when you start using a new keyboard, there is a chance that the key mappings are different, specially if we are talking about a Apple keyboard.

To change the mappings of the keyboard used in your system you need to:

  • Open the system settings

    enter image description here

  • Select Keyboard

    enter image description here

  • Select Layout Settings

    enter image description here

  • Right bellow the list of keyboard mappings active there is a little + button, press it and you will be able to add and select a new keyboard mapping

    enter image description here

When selecting a new keyboard mapping from the list you will be able to press the Preview button to have a look at the look and key distribution of the keyboard that will be a in use, try to match as close as you can to yours.

5
  • Thanks for your reply. I found that dialog but can't really find any layout similar to the mini layout used by this keyboard. (Just to clarify - it's a copy, not an actual apple keyboard. It's this one, just to give you an idea of the layout amazon.co.uk/gp/product/B004IRXNGO/ref=oh_details_o02_s00_i00). – swedishhh Jul 29 '12 at 20:59
  • 1
    It seems unfortunate that ubuntu was able to use the keyboard to enable me to type my password, but not after completing login. Is there some way to find out what layout setting it has at that point, and apply that to my login? – swedishhh Jul 29 '12 at 21:00
  • 1
    @swedishhh that looks like a standard US, international keyboard layout, make sure that you are running only with 1 layout for now (remove the others, you can add them later) – Bruno Pereira Jul 29 '12 at 21:00
  • Thanks @bruno - played around with most of the english layouts now - no luck with any though. – swedishhh Jul 29 '12 at 21:33
  • 2
    See here ubuntuforums.org/showthread.php?p=12138259 numlock is on by default after logging into X. I can turn it off with another keyboard but not the apple kbd. Also function keys don't work yet. I'll post more if I make progress. – swedishhh Jul 29 '12 at 22:30
3

The numlock issue seemed to go away.

To fix the functions keys I just followed this:

https://help.ubuntu.com/community/AppleKeyboard#Change_Function_Key_behavior

  1. Append the configuration line to the file /etc/modprobe.d/hid_apple.conf creating it if necessary:

    echo options hid_apple fnmode=2 | sudo tee -a /etc/modprobe.d/hid_apple.conf
    
  2. Notify the hid_apple module to reload its configuration

    sudo update-initramfs -u
    
  3. Reboot

0

Ubuntu Community Wiki - Apple Keyboards
Numlock on Apple Wireless Keyboard

If the Apple Wirelesss Keyboard stops working after log-in where most keys do not work and some keys on the right side produce numbers, it is because numlock is enabled by default. Numlock can be switched off by pressing fn-F6 twice. The keyboard then works normally again.

To disable numlock by default, go to System -> Preferences -> Keyboard -> Layout -> Layout Options -> Miscellaneous compatibility options -> turn on "Default numeric keypad keys"

This setting takes effect after logging in and does not affect the graphical login screen or local consoles.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.