I'm trying to implement the fixes from Adobe (as mentioned in this other question) but I'm having no success.

I'm running 64-bit 12.04. When I try the Flash test as described on this Adobe guide:

  1. First, launch the Adobe demo video player container: http://drmtest2.adobe.com:8080/SVP/SampleVideoPlayer_FP.html

    Note the Adobe Flash Player version in the lower left of the demo video shell. Make sure that indicate 11.2 or higher

  2. Play sample protected content.

    Enter the following URL in the field "Input the video URL: (case-sensitive) http://drmtest2.adobe.com:8080/Content/anonymous.f4v

  3. Press the [Play] button at the bottom of the video container.

Well that doesn't work. From that test page, when I select the "Show DRM Events" checkbox I get "Error #3344 [MissingAdobeCPModule]", and then it just sits there and nothing plays.

I've installed the HAL (several times) and cleared out the directories from my home .adobe directory as those instructions say, restarted Firefox, etc.

The Flash info page says "You have version 11,2,202,160 installed" and that 236 is the more up-to-date version, but I can't figure out how to install that. (I've tried, but to no avail; I just end up with 160).

So does anybody have ideas on what to do to make this work?


I'd followed most of the advice I could find online, but ran across these extra steps to get the HAL working. It comes from a post on Amazon's Prime Instant Video support thread:

Stephen Gutknecht says:

On a new (virgin) install of Ubuntu 13.04 x64/x32 - there are some steps that I don't see getting enough attention.

In addition to:

close your Chromium/Chrome and Firefox:
sudo apt-get install libhal1 hal

***also do***

sudo mkdir /etc/hal/fdi/preprobe
sudo mkdir /etc/hal/fdi/information
/usr/sbin/hald --daemon=yes --verbose=yes
rm -rf ~/.adobe
rm -rf ~/.macromedia

Then open Chromium / Firefox fresh and give it a try!

This is what I did and have DRM FLash videos working smoothly in Chrome on Ubuntu using the Adobe Flash plugin with HAL installed.

| improve this answer | |

OK well that was dumb. I had been installing (and re-installing) flashplugin-installer. When I instead switched to adobe-flashplugin, that brought my version up to 236 (that is, 11,2,202,236) and it also made the test page work.

Subsequently, a test at the NBC streaming site also worked.

Thus, it appears that in addition to doing the HAL stuff as described in the other question, it may also be necessary to be running the latest Flash version. For me, that required installing adobe-flashplugin instead of flashplugin-installer.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.