I've installed ubuntu 12.04, but after rebooting I get the message:

GRUB loading:
Welcome to GRUB!

error: file '/grub/i386-pc/normal.mod' not found
Entering rescue mode...
grub rescue>

I have the following partitons setup:

/dev/sda6:  /boot  ext2
/dev/sda9:  /      ext4
/dev/sda8:  swap
/dev/sda7:  /home  ext4

I guess that some of the prefixes for GRUB are wrong due to the /boot partition? Or there might be a problem with EFI? The hardware is a 1015bx asus netbook with c-60 amd fusion chipset. How can I fix this GRUB problem from the rescue prompt?

  • To people considering closing this question: The OP has solved the problem and the OP's solution has been posted as an answer, so this question should not be closed as too localized. Commented Aug 30, 2012 at 1:19
  • @EliahKagan That answer has since been deleted. What do you suggest now?
    – jokerdino
    Commented Sep 2, 2012 at 6:22
  • @jokerdino There may have been some good reason for it to have been deleted. I've pinged the user in chat who posted and (I believe) subsequently deleted it. Maybe it was wrong and we don't know if/how the problem was solved (in which case this should be closed as too localized). We'll probably find out soon. Commented Sep 2, 2012 at 11:48
  • Hi, I had posted a perfectly fine solution and somehow it got removed. I don't know the exact details anymore, but I think I used the program Boot-Repair from the live cd. This solution was given in the documentation: help.ubuntu.com/community/Grub2/Troubleshooting if you want I can re-answer my question...
    – 3cHeLoN
    Commented Sep 3, 2012 at 9:50
  • I have the same problem, and none of these answers are correct. My /boot includes the directory /boot/grub/x86_64-efi/normal.mod, so there seems to be a package issue involved in some cases as well (v 12.10).
    – user239558
    Commented Mar 6, 2013 at 8:21

2 Answers 2


Boot your system into a live CD. Mount your system into the live CD:

sudo mount /dev/sda1 /mnt
sudo mount --bind /dev /mnt/dev
sudo mount --bind /dev/pts  /mnt/dev/pts
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys  /mnt/sys

Log into the mounted system:

sudo chroot /mnt

Install grub:

grub-install --boot-directory=/boot/ --recheck /dev/sda

Reboot your system.


You can type the command at grub rescue:

grub-install /dev/sda

Then quit the grub rescue mode and reboot the machine

Or :

You can install GRUB on your hard disk. You can do this by using bootable Ubuntu CD.

  1. Boot to LiveCD

  2. When you get Ubuntu Live Desktop. Open terminal ( What is a terminal and how do I open and use it? ) and type the following one line at a time:

    sudo grub-install /dev/sda
    sudo update-grub

You are done now. Reboot the machine.

This will install grub on MBR of your hard disk with dual boot. Try the latest Ubuntu 12.04 LTS.

  • 5
    No, you can't do grub-install command in grub-rescue prompt. It is totally Wrong. I suggest you to remove the first part. And yes, the second part is better, but again you can't run sudo update-grub from Live CD as far as I know
    – Anwar
    Commented Aug 30, 2012 at 6:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .