My problem is that i want to install latest blender and upgrade it automatically via sudo apt-get update && sudo apt-get upgrade . So, i tried to add a repository

sudo add-apt-repository ppa:cheleb/blender-svn 
sudo apt-get update
sudo apt-get install blender

So, after the first line executed in terminal it gives me:

You are about to add the following PPA to your system:
 More info: https://launchpad.net/~cheleb/+archive/blender-svn
Press [ENTER] to continue or ctrl-c to cancel adding it

 Executing: gpg --ignore-time-conflict --no-options
 --no-default-keyring --secret-keyring /tmp/tmp.pvnVePB2Fl --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com:80/ --recv tag:launchpad.net:2008:redacted
 gpg: "tag:launchpad.net:2008:redacted" not a key ID: skipping

And when i am running the second line it gives me:

W: Failed to fetch http://ppa.launchpad.net/cheleb/blender-svn/ubuntu/dists/precise/main/source/Sources  404  Not Found

W: Failed to fetch
404  Not Found

W: Failed to fetch
 404  Not Found

E: Some index files failed to download. They have been ignored, or old
ones used instead.

Q: why this ppa does not work and what should i do to have blender updated automatically!?!Thanks


IF you Actually click on the links you can find out why, the address just doesn't exist.

And if you go to the launchpad page: https://launchpad.net/~cheleb/+archive/blender-svn you can see it's not accessible.

@PhoneixS asked the maintainer of the PPA Ralf Hölzemer (cheleb) and he said: "...cannot maintain that PPA any longer."

You can however Install it from this other PPA:


sudo add-apt-repository ppa:thomas-schiex/blender
sudo apt-get update
sudo apt-get install blender

The builds are recent so you still get the newest Blender.

Here you can find Instructions on how to Compile Blender from SVN


  • Yes, but for how long? And why is this happening? – gabriel Jul 29 '12 at 7:28
  • I don't know there is however another Blender PPA I'll add it. – Uri Herrera Jul 29 '12 at 7:30
  • Yes, I searched for another and i found this repository you mentioned. My problem is that i am not sure if this is the newest. How can i see that? – gabriel Jul 29 '12 at 7:33
  • You can see that the most recent build was 8 days ago 2.63.1+svn49102 whereas the current SVN from the Blender SVN is Revision 49349 so it's not far behind. Of course the better option to keep blender updated is to compile it and install from SVN, although you'll have to that manually. – Uri Herrera Jul 29 '12 at 7:35
  • 2
    A little information of why is down. I ask to Ralf Hölzemer (cheleb) and he said that he "...cannot maintain that PPA any longer." but he also mention to use irie PPA. – PhoneixS Aug 2 '12 at 7:11

And now that Irie PPA is not updated anymore, to get the latest version (updated weekly), you can use this instead:

sudo add-apt-repository ppa:thomas-schiex/blender
sudo apt-get update
sudo apt-get install blender

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.