I am new to Ubuntu (AMD64) and am attempting to install it on my laptop which already has Windows 7 Home Premium x64.

I currently have two partitions on my HDD and I was planning on repartitioning my secondary partition to make room for a third to use for Ubuntu. However when I attempt to install I get the following message:

"This computer currently has no detected operating systems"

Choosing "something else" takes me to the partitions. However, it only detects a single unpartitioned space (my entire HDD) even though I actually have 2 partitions taking up plenty of space.

By no means can I detect my two partitions using any method. Is it possible the 32 bit installation might be more successful? (I doubt it but I had to ask)



250gb. I have two partitions for windows (one main and another for storage) as well as an empty third partition with 20gb that I intend to use for Ubuntu. None are detected, however.

I finally fixed the problem. when I ran

sudo fdisk -l

it gave me several partitions in the list, so I tried running fixparts on individual partitions, which ended up being inconclusive (and confusing)

Then I decided to try to run fixparts over the entire unpartitioned space

sudo fixparts /dev/sda


sudo fixparts /dev/sda1

sudo fixparts /dev/sda2

(individual partitions) and so on.

After simply running the command on the entire hdd, it quickly finished and alas it was fixed! Going back to the installation, it detected my Windows 7 installation, and also detected all existing partitions in the custom install mode. Furthermore, my data on my other partitions was left completely unscathed. It fixed my problem at no cost.

marked as duplicate by Eliah Kagan, Luis Alvarado Jul 24 '14 at 17:32

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • What size is your entire drive? – Mitch Jul 29 '12 at 7:48

I had a similar problem where somehow I had two conflicting partition tables. I used the livecd and then used a utility called fixparts which sorted the problem out. Details here: http://www.rodsbooks.com/fixparts/.

  • 2
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – hexafraction Aug 15 '12 at 13:57

This was most helpful.

I didn't know which option to choose after entering

sudo fixparts /dev/sda

but I found the answer 'w' here: Ubuntu 13.04 not detecting Windows 7 during Install

I've installed ubuntu alongside windows several times, but I've never run into the "missing dual-boot option" before.

The solution took quite a bit of searching to find.

If this is a new problem, due to some recent modification of Windows 7, perhaps your way to handle it should be posted in a more prominent site, (eg in the ubuntu download site).

Thanks again for the solution.

  • Great! Would you like to mention what commands did you enter before and after? I mean, if you can explain the whole process. That will help a lot of users :) – Lucio Oct 5 '13 at 0:06

Not the answer you're looking for? Browse other questions tagged or ask your own question.