I have a Samsung Galaxy s3 running the stock Samsung ROM and I'm trying to transfer files - videos, photos, music and downloads, from my handset to my system via USB running Ubuntu 12.04.

I have followed to links suggested

But it all goes over my head. Can anyone help me with a simple GUI program or a link so I can simply copy and paste selected files from my phone onto my system?

  • 1
    This is a very frustrating issue with Linux at the present. The problem is that linux does not natively support the new MTP procotol that the Android v4.0 devices use for storage access over USB cable. I have the same problem. I havent found any reliable solution. Some have reported success, but it is mostly not reproducible or unstable. I hope this will get fixed soon.
    – ECII
    Jul 29 '12 at 9:47
  • Hmm what a pity... Has anyone tried running kies using wine?
    – nense
    Aug 2 '12 at 9:08

11 Answers 11


You can get file access to your phone's internal storage (/mnt/sdcard) or your external SD card (/mnt/extSdCard/) using gMTP as another replier @Easty noted (http://www.humans-enabled.com/2011/12/how-to-fix-samsung-galaxy-nexus-mtp.html).

You'll need to install libmtp (instruction are on that page and easily found elsewhere) and gMTP.

Once everything's installed do the following:

  1. Plug in your phone to the USB cable connected to your computer
  2. Swipe down from the top and verify it's connected as "a Media Device" (MTP), if not click on the notification to change from Camera mode (PTP) to Media Device (MTP)
  3. launch gmtp from your launcher (windows key then type 'gmtp')
  4. When your phone connects (it may take some time) you may be prompted to connect to Phone or Card (drop-down menu) - pick the one you want to access, in this case 'Card'
  5. Voila! You can browse the card, select files and download them to your computer with the Download button.

If you want to switch from browsing the SD card to the phone's memory simply click disconnect and then connect in gmtp and select 'Phone' instead of 'Card'.

Hope this helps, it certainly did for me! Thanks @Easty!


Alternatively, just buy micro USB cable (OTG) from ebay , original Samsung or 3rd party brands are available. Using that cable you can connect external USB storage , external HDD and any external storage to your galaxy s3. S3 will detect and u can transfer files or any media between s3 to USB storage.

You don't need computer , just plug and play. Or if u need to connect PC to your s3, you can use this cable or install KIES ( samsung's sync software ).

NOTE: DO NOTE CONFUSE USB "otg" cable with micro USB cable comes with the Samsung device for charging and syncing .


Try the following. This was tested on Galaxy SII, i am assuming it will work for SIII as well

  1. go to Menu -> Settings -> Wireless and network -> USB utilities
  2. Click on Connect Storage to PC
  3. Connect the USB cable to your pc.
  4. Click on Connect USB storage
  5. Use your file manager to install/copy/paste.
  6. Once finished, click on Disconnect storage from PC to disconnect and unmount drive from Ubuntu.

Reference: http://www.tuxtrix.com/2011/07/how-to-access-samsung-galaxy-s-ii-usb.html

  • 6
    S3 not working as with S2
    – jaezcurra
    Jul 30 '12 at 9:31

I am currently running Ubuntu 12.10 and have a Sprint Samsung Galaxy S3 running Cyanogenmod. I have yet to get MTP or PTP working successfully.

However, I am able to very easily download and upload data (pictures, music, videos, files). On my Android device, I simply run Dropbear SSH. And then from my Ubuntu desktop, I use rsync to send and receive data.


I had similar problem with my Galaxy S2. When I connected it to Ubuntu, it was never recognized. I use the following trick:

  • On your android phone, go to Application->Settings
  • In there, go to Wirelessand Network and select USB Utilities
  • Click on Connect Storage to PC
  • A message should pop up: Connect USB cable to use mass storage
  • Now connect the USB cable to computer
  • A green android robot should be on display with an option of “Connect USB storage“, click on it
  • The green robot turns orange now and now you can access the files on the SD card of your phone

Source: After I fixed, I wrote this on my blog: http://www.computerandyou.net/2012/01/how-to-fix-android-samsung-galaxy-s2-not-recognized-on-linux/


Alternatively, you can use gMTP. A GUI tool to use with MTP protocol. You may have trouble with libmtp. So better to install it before hand like this:

  • Download MTP library libmtp from Sourceforge: http://sourceforge.net/projects/libmtp/files/libmtp/
  • use the following commands one by one to install it:

    cd Downloads
    tar xvzf libmtp-1.1.5.tar.gz
    cd libmtp-1.1.5
    ./configure --prefix=/usr
    sudo make install
  • Now install gMTP:

    sudo apt-get install gmtp
  • Launch gMTP and connect your phone.

Source: I wrote this detailed article with picture for my Kindle Fire connection problem with Ubuntu. It may come handy.


Please first check that there is in fact a microsd card in your device. I got a new device and sort of assumed that it had a microsd card, but it didn't. Once I put in a microsd card, the instructions given by Easty worked.


I have found that the command line works very well for this, with a nifty tool from the Software Centre called adb (Android Debug Bridge).

Install with sudo apt-get install android-tools-adb or android-tools-adb:i386

Plug in the phone, do adb pull <remote> <local> to download files, or adb shell to navigate the phone directories and get to know where stuff is.

All the info you need is here: http://developer.android.com/tools/help/adb.html

  • 1
    I forgot to add: you probably need to enable USB debugging in the phone. System settings > Developer options. If you can't see Developer options, go into About phone and tap seven times on Build number at the very bottom. Yes, really. Jan 8 '13 at 19:08

An easier solution (compared to compiling libmtp yourself) would be to install go-mtpfs. It includes the latest version of libmtp, and I can verify it works with my GS3 running CM 10. You can also install the go-mtpfs-unity package, which comes with a nice launcher icon and functionality.

To install, run

sudo add-apt-repository ppa:webupd8team/unstable
sudo apt-get update
sudo apt-get install go-mtpfs-unity

Full directions can be found here: http://www.webupd8.org/2012/12/how-to-mount-android-40-ubuntu-go-mtpfs.html

The easiest solution of all would be to use AirDroid, free on the Play Store. You just install the app on your phone, start it, and point any desktop web browser to the address it gives you. From there you can access the file system, upload/download photos and videos, even send SMS messages.

I think the current version (in the Play Store) requires the phone and computer to be on the same WiFi network, but there's a v2 beta right now where this isn't necessary.


I have found the most practical solution in order to access files on Samsung galaxy s3 external SD card using Ubuntu 12.04 or later, and Nautilus file explorer

  1. The Samsung Galaxy S3 and the Ubuntu PC need to be at the same WiFi network/hotspot. Or you can use your Samsung Galaxy S3 as a USB modem to connect the Ubuntu PC (this is the faster file transfer solution).

    Samsung Galaxy s3 settings:

  2. You have to buy DAVDRIVE at the Google play store $1.26

  3. You have to change the DAVDRIVE: Settings > Filesystem > Filesystem Root > /

  4. Run the DAVDRIVE app.

    Ubuntu Settings:

  5. Open Nautilus > File > Connect to Server

  6. Set to WebDAV (HTTP), write the server IP address, port, user and password (given by the DAVDRIVE app)

  7. When you have successfully open the server connection folder with Nautilus, go to:

    Nautilus > WebDAV folder > Storage > extSdCard

Note: If you don't need to access the extSdCard, you only need to install the DAVDRIVE lite free app version.


Alternative Solution;

I use ubuntu one for sharing files between my android device and my desktop. If you're over a wireless network this is the easiest way of transferring files between android devices and ubuntu.

I have tried gmpt solutions at once but didn't have luck. This can be the last solution but it is working gently at least.


I've updated my computer to 14.04 and with it, you just connect the USB cable between your Galaxy S3 and your computer. After having done it, a new window will pop up at center of your computer's screen asking for what to do on the telephone's folders. In other words, it mounts successfully.

Everything works automatically.

Hope it helps.

Not the answer you're looking for? Browse other questions tagged or ask your own question.