For the last few hours, my upgrade window to 12.04 has been stalled at configuring lswh. The top of the terminal window says

irqbalance start/running

There's a fairly long line of errors in the terminal like

error cannot seek /dev/sdc,

most of them coming after the "Generating grub.cfg". A the very bottom of the terminal it says Found Ubuntu 8.04.2 on /dev/sdb3 and then "done" on the final line.

Reading other threads on freezes during upgrade1 gives me some hope I can open another terminal window and fix this and continue with the upgrade, but I haven't found what that command might be. I found some leads here where lshw hangs:

  • bugs.launchpad.net/ubuntu/+source/lshw/+bug/218864

But the solution assumes I can just run a patch, which I can't don in the middle of an upgrade.

These two issues:

seem to suggestion killing or disabling the os-prober, but I'm not sure if I can do that mid-upgrade.

Any suggestions for fixing this?


CTRL-C the upgrade, do whatever you want to do, then dpkg --configure -a to restart it.

  • No, the files should be okay - use sudo! Hmm strange... I would recommend backing up important files or moving them, and doing a fresh install - dist-upgrades cause a lot of problems when they go wrong. – whiskers75 Jul 28 '12 at 17:54
  • Thanks for your help, whiskers75. I used sudo to make the change and it worked. Then I tried the dpkg --configure -a to restart it and go "error: dpkg status database is locked by another process". It seems simply hitting ctrl+c in the dist-upgrade window didn't work. How do I kill the dist-upgrade process from another terminal? – Tim Nafziger Jul 28 '12 at 18:13
  • pkill apt-get and pkill dpkg. – whiskers75 Jul 28 '12 at 18:15
  • okay, the pkill worked and I was able to run 'dpkg --configure -a'. Now I run into a whole string of "dependency problems - leaving unconfigured" that conclude with "Processing was halted because there were too many errors." – Tim Nafziger Jul 28 '12 at 18:43
  • 2
    I should add that the key change I made to the system files that's not listed above was "The workaround I finally found (somewhere on Ubuntu forums, I think) was to append this line to the bottom of /etc/default/grub: GRUB_DISABLE_OS_PROBER=true" from eyemeansit.wordpress.com/2010/08/13/… – Tim Nafziger Jul 28 '12 at 20:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.