I cannot log in to the nbcolympics.com (USA) site on Ubuntu. (I have tried on two computers, with Chromium and Firefox on each.) I choose "Click here to get started", then the site asks for my cable provider. I choose it, enter my password, and it appears to accept it. The next screen that loads again says "Click here to get started". If I click it and choose my provider, it doesn't even ask for my password, it just says signing in and the process repeats. A couple of points:

  1. It works fine on Windows XP.
  2. If I purposely enter a wrong password, it tells me so. This error only occurs if I have the password correct.

Has anyone been able to make it work?


As per this post on the Adobe website:

Step One: Install HAL

sudo apt-get install hal

Step Two: Quit your web browser

Step Three: Clean out the Adobe Flash folder:

cd ~/.adobe/Flash_Player
rm -rf NativeCache AssetCache APSPrivateData2

This process worked for me. In my case, I'd been able to go to nbcolympics.com and click the log to begin the verification process, but never given the chance to enter my Comcast credentials. Doing the steps above fixed everything.

  • Works perfectly now. This also fixed my Amazon Prime "updating player" issue as a side benefit. :) I noticed the same solution is given to the Amazon problem here. – Andy Jul 29 '12 at 0:29
  • 1
    Great! Glad it worked for you. As an aside, I had used this solution on one computer where Firefox was the default browser, and it worked as I'd hoped. On a different system, with Google Chrome, it was not successful. A solution (albeit not a perfect one), is to go into Chrome's chrome://plugins page and disable the built-in Pepper API Flash, which forces Chrome to use the system-wide Flash (installed manually). This negates the advantages in security to using Chrome's built-in Flash, but if you're trying to get the Olympics to stream properly, it is a workable solution. – user79939 Jul 29 '12 at 1:58
  • Excellent. Works on chromium browser for me on 12.04. See also askubuntu.com/questions/145735/… – John S Gruber Jul 29 '12 at 5:37
  • This was not successful for me. I've got 12.04, and an up-to-date Firefox etc. I've installed HAL, bounced the browser, cleaned and re-cleaned my .adobe/Flash_Player directory, and still I get the same failure. From the Adobe test page, I get the "Error #3344 [MissingAdobeCPModule]" failure. Chrome doesn't work either, and I can't get Chrome to use the system-installed Flash instead of its own. – Pointy Jul 29 '12 at 13:31
  • OK see this follow-up question too - it may help. – Pointy Jul 29 '12 at 14:10

Firefox 14.0.1 on Ubuntu 12.0.4

I had the indentical problem (the login/password were correct, but it just kept asking me to login again and would never actually play "live" content).

I installed "hal" per the instructions above and IT WORKS.

Note: I am running the Ubuntu in a VM (Vmware) because my Ubuntu workstations are not current enough to run new enough Flash (dependency hell if I try). The only potential issue is competition with other sound players running natively on the workstation. I had to shut down another sound player on the workstation before starting the VM.

!!! Notice that "hal" has been deprecated -- hal is old stuff. Adobe has announced that it is discontinuing support for Flash on Linux, so what do we do in a few months???



  1. Uninstall moonlight 2.0 plugin

  2. Install moonlight 3.0

  3. Play video

  • Thanks. How do you recommend I do that? Within firefox/chromium, or the mono package within synaptic? – Andy Jul 28 '12 at 15:58
  • 1
    This didn't work: I tried both as a plugin from go-mono, and installed libmono-wcf3.0-cil from synaptic. Also tried booting from a USB disk. Are the olympics using silverlight this time? It looks like they moved away from it and it is based on flash and youtube. – Andy Jul 28 '12 at 16:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.